You receive a "There is no printer installed" error message when you try to print from PowerPoint 2000 (223021)



The information in this article applies to:

  • Microsoft PowerPoint 2000

This article was previously published under Q223021
For a Microsoft PowerPoint 97 for Windows, PowerPoint for Windows 95 7.0 version of this article, see 140754.

SYMPTOMS

When you attempt to print within PowerPoint 2000, you receive the following error message:
There is no printer installed.


NOTE: Microsoft Office 2000 has built-in functionality that allows you to get more information about difficult-to-troubleshoot alerts or error messages. If you want to enable this functionality for this and other error messages in Microsoft Office 2000, please download the Microsoft Office 2000 Customizable Alerts file from the Microsoft Office Update Web site at the following address: NOTE: If you reached this article by clicking the Web Info button in an error message, you already have Customizable Alerts enabled.

CAUSE

This error message means that either you do not have a default printer installed, or that Microsoft PowerPoint cannot find the default printer.

RESOLUTION

If you do not have a default printer, use the Add Printer wizard to install one. To do this, follow these steps:
  1. On the Windows Start menu, point to Settings, and then click Printers.
  2. Double-click Add Printer, and follow the instructions.
NOTE: Some printers have their own setup routines that bypass the Add Printer wizard. Follow the instructions in your printer's documentation.

If you already have a default printer, there may be a problem with your Win.ini file, which contains configuration information for your system. The problem may be any of the following:
  • You do not have a Win.ini file.
  • The Devices section of the Win.ini file is missing.
  • The Devices section of the Win.ini file contains incomplete or incorrect information.
  • The Win.ini file exceeds the 64 KB size limit, or is corrupted.
You may be able to fix the problem by reinstalling your printer driver, or correcting the driver's entry in your Win.ini file. If both of these methods fail, you will need to use Windows Setup to reinstall the Win.ini file from your Windows 95/98 CD-ROM.

Method 1: Reinstall the Printer Driver

To reinstall the printer driver, follow these steps:
  1. On the Windows Start menu, point to Settings, and then click Printers.
  2. Right-click your default printer, and click Delete. If you are prompted to remove extra files left on the system, click Yes.
  3. Double-click Add Printer, and follow the instructions to reinstall your printer driver.
When you reinstall your printer driver, Windows writes the correct entries for the Ports, Printer Ports, and Windows sections in the Win.ini file.

Method 2: Correct an Entry in the Win.ini File

To correct an entry in the Win.ini file, follow these steps:

NOTE: You will need to know the name of your printer driver to complete this procedure.
  1. On the Windows Start menu, point to Find, and then click Files or Folders.
  2. In the Named box, type win.ini.
  3. In the Look In list, click your hard disk letter.
  4. Select the Include Subfolders check box, and then click Find Now.
  5. Check the file size in the Size column. If it is larger than 64 KB, the Win.ini file is too big. This could be the cause of the error message.
  6. Double-click the Win.ini file. This will open it in Notepad.
  7. Look for duplicate entries or sections. If you find any, delete them.
  8. The Devices section should list the friendly name of your printer, followed by an equals sign, the driver name, comma, and then the port or network path.

    If the Devices section is missing, add it. Here's an example:
    [Devices]
    HP LaserJet 4/4M=HPPCL5MS,LPT1:
    HP LaserJet IIISi=HPPCL5MS,\\Server\Sharename
  9. If you made any changes, click Save on the File menu, and then attempt to print again.

Method 3: Create a new Win.ini

If the previous methods fail, your Win.ini may be corrupted, or there may be other problems with the file. Use method 3 only after you attempt methods 1 and 2.
To create a new Win.ini file, follow these steps:
  1. To find the Win.ini file, use method 2.
  2. Right-click the Win.ini file, click Rename, and type win.old.
  3. Insert your Windows 95/98 CD-ROM.
  4. In the Run Setup Again? dialog box, click Restore Windows files that are changed or corrupted, and then follow the on-screen directions.
This method creates a new, complete Win.ini with all of the required sections.

NOTE: If you rename or delete the Win.ini file, and then restart your computer without running Setup, Windows 95/98 will automatically create a new Win.ini. However, the new Win.ini file will contain only the Desktop and Embedding sections. The Devices section, and all other sections configured by your system, will be missing.

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Modification Type:MinorLast Reviewed:12/2/2005
Keywords:kbtshoot kbsetup kbprinters kbprint kberrmsg kbprb KB223021