OL98: Outlook Gives Error for Migrated Schedule+ Resource Account (222920)



The information in this article applies to:

  • Microsoft Outlook 98

This article was previously published under Q222920

SYMPTOMS

When you attempt to set up a meeting request using a resource account that has been migrated from Schedule+ to Outlook, as described in article 181988, the following error message is displayed
Unable to directly book the resource <resouce account>. This resource does not allow direct booking for recurring appointments. Would you like to send a meeting request to the resource instead? If not, you may want to remove the resource from the attendee list.
where <resouce account> is the name of the resource account. After clicking Yes, the meeting request for <resource account> is booked as expected.

CAUSE

The MAPI property PR_SCHDINFO_RESOURCE_TYPE is set to 1 for a Schedule+ resource account. Even after migrating this account the property value remains intact which causes Outlook to treat this account as Schedule+ account, reporting an erroneous message.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

File name         Version
--------------------------
Outllib.dll       8.5:6323.0
					
This version number will be seen on About Microsoft Outlook, on the Help menu.


STATUS

Microsoft has confirmed this to be a problem in Microsoft Outlook 98.

MORE INFORMATION

This fix should only be applied to the computer where the resource account resides. Alternatively, a user with proper permisions can create a profile that points to the resource account and run the patch locally.

After applying the fix, start Outlook with the profile that points to theresource account. Create and send a meeting request back to the resource account.

Modification Type:MinorLast Reviewed:10/13/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix KB222920