Task Scheduler Does Not Run Scheduled Tasks on Backup Domain Controller (BDC) (222628)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0

This article was previously published under Q222628

SYMPTOMS

When you schedule jobs using Task Scheduler, the jobs may not start. If you view the Task Scheduler log, the following error message may be displayed:
The attempt to log on to the account associated with the task failed, therefore, the task did not run.
The specific error is:
memory address: Logon failure: the user has not been granted the requested logon type at this computer. Verify that the task's Run-as name and password are valid and try again.
NOTE: This behavior occurs even if you are logged on to the backup domain controller (BDC) as an administrator.

CAUSE

This behavior occurs when the Log on as a batch job setting is not selected. This right is required to run a scheduled task.

RESOLUTION

To resolve this issue:
  1. In User Manager for Domains, click Policies, and then click User Rights.
  2. Click to select the Show Advanced User Rights check box.
  3. Click Log on as a batch job.
  4. Add the Administrators group to the list of users that are granted this right.
  5. Restart the computer.

Modification Type:MajorLast Reviewed:12/5/2003
Keywords:kbenv kbprb KB222628