XFOR: Internet Mail Service Sends MIME Plain Text as Both HTML and Plain Text (222508)
The information in this article applies to:
- Microsoft Exchange Server 5.5
This article was previously published under Q222508 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you send plain text from an Outlook client that has an Exchange Server as the backend with the Internet Mail Service configured to send plain text or HTML, the Internet Mail Service overrides the user's choice, and sends both plain text and HTML. When MCI Mail or other plain text mail readers receive a message as MIME/multipart/alternative, the recipient gets one e-mail message with plain text at the top followed by the same message embedded in HTML tags.
CAUSE
The Internet Mail Service doesn't get the sender's option in the message. As a result it, sends both the plain text and the HTML.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
191014 XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack
The English version of this fix should have the following file attributes or later:
Component: Internet Mail Service
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Gapi32.dll | 5.5.2571.0 | Imcmsg.dll | 5.5.2571.0 | Mdbmsg.dll | 5.5.2571.0 | Msexcimc.exe | 5.5.2571.0 | Store.exe | 5.5.2571.0 |
This hotfix has been posted to the following Internet location as Psp2imca.zip and Psp2imci.zip: More Information
In addition to the new files noted above and the client-side updates, the following registry changes must be made to enable this functionality. To make the registry changes, perform the following steps: WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. - Stop the Microsoft Exchange Internet Mail Service and the Microsoft Exchange Information Store service.
- Apply the fixed files noted above.
- Start Registry Editor (Regedt32.exe)
- Go to the following location in the registry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIMC\Parameters - On the Edit menu, click Add Value.
Value Name: SendPlainTextAsIs Data Type: REG_DWORD Value: 0x0, 0x1 Default: 0x0 (not in registry by default)
After this key is set, all plain text mail generated by Outlook will be sent out as plain text without any HTML tags.
- Click OK, and quit Registry Editor.
- Restart the Microsoft Exchange Information Store service and Microsoft Exchange Internet Mail Service.
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 3.
Modification Type: | Minor | Last Reviewed: | 9/22/2005 |
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Keywords: | kbHotfixServer kbQFE EXC55SP3Fix kbbug kbfix kbQFE KB222508 |
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