You receive an "A required .DLL file, WININET.DLL, was not found" error message when you start Publisher 2000 (221293)



The information in this article applies to:

  • Microsoft Office 2000
  • Microsoft Publisher 2000

This article was previously published under Q221293

SYMPTOMS

When you try to start Microsoft Publisher, one of the following problems may occur:
  • The following error message appears:
    A required .DLL file, WININET.DLL, was not found.
    When you click OK, Microsoft Publisher does not start.

    -or-

  • No error message appears, and you cannot start Microsoft Publisher.

CAUSE

This problem occurs when the following conditions are true:
  • You have installed Microsoft Internet Explorer 4.01 and Microsoft Publisher 98 on Microsoft Windows 95.

    -and-

  • You upgrade to Microsoft Publisher 2000 from Microsoft Office 2000 Disk 2 but do not upgrade to Microsoft Internet Explorer 5.0.

    -and-

  • You uninstall Microsoft Internet Explorer 4.01.

WORKAROUND

To work around this problem, uninstall and reinstall Microsoft Office 2000 Disk 2 after you uninstall Microsoft Internet Explorer 4.01.

Uninstall Microsoft Internet Explorer 4.01

To uninstall Microsoft Internet Explorer 4.01, follow these steps:
  1. On the Windows Start menu, point to Settings, and click Control Panel.
  2. Double-click Add/Remove Programs.
  3. On the Install/Uninstall tab, select Microsoft Internet Explorer 4.01, and click Add/Remove.
  4. Click Remove All.

Uninstall Microsoft Office 2000 Disk 2

To uninstall Microsoft Office 2000 Disk 2, follow these steps:
  1. On the Windows Start menu, point to Settings, and click Control Panel.
  2. Double-click Add/Remove Programs.
  3. On the Install/Uninstall tab, select Microsoft Office 2000 Disk 2, and click Add/Remove.
  4. Click Remove All.

Install Microsoft Office 2000 Disk 2 Without Installing Internet Explorer 5.0

To install Microsoft Office 2000 Disk 2 without installing Internet Explorer 5.0, follow these steps:
  1. Insert the Microsoft Office 2000 Disk 2 into the CD-ROM drive.
  2. On the Windows Start menu, click Run.
  3. In the Run dialog box, type the following text, and click OK:

    <drive letter>:\Setup

    Where <drive letter> is the letter assigned to the CD-ROM disk drive.
  4. Type your customer information and CD Key, and then click Next.
  5. Accept the terms in the License Agreement, and then click Next.
  6. Click Customize, choose the installation location for Microsoft Office, and then click Next.
  7. In the Microsoft Internet Explorer 5.0 Installation dialog box, select Windows Web Browsing Component Only and click Next.
  8. Click Install Now to complete the installation of Microsoft Office.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:9/10/2004
Keywords:kbstartprogram kbtshoot kbprb kberrmsg kbnofix KB221293