MCIS SMTP Non-Delivery Report Occurs During Directory SQL Server Interruption (221104)
The information in this article applies to:
- Microsoft Commercial Internet System 2.0
- Microsoft Site Server 3.0
This article was previously published under Q221104 SYMPTOMS
When a SQL Server partition for a Site Server Personalization and Membership (P&M) directory fails over, messages may be returned with a non-delivery report (NDR). The NDR returned by the postmaster contains the following message:
Routing Table Database Transaction Failed
CAUSE
Default SMTP Delivery properties are set to 48 attempts, 60 minutes each, for both Local and Remote queues. This allows for a significant total period of attempts, and accommodates a relatively lengthy period of time during which P&M Authentication may be unavailable for a variety of reasons.
If the maximum number of retries has been dropped to two or three, this may result in a dramatically decreased period of effective delivery attempts. Only N-1 attempts are likely to occur if N maximum retries are configured. Due to additional processing delays, it is unlikely that the actual process of performing all N attempts will complete in the total time calculated. The final attempt that is expected is unlikely to occur.
RESOLUTION
To resolve this problem, increase the maximum number of attempts and the retry interval. This will help decrease the possibility of NDRs due to periods of LDAP P&M resolution failure. By increasing the number of retries, the resolution eventually completes, allowing the messages to be delivered when the SQL Server computer is returned to operation.
STATUS
Microsoft has confirmed this to be a problem in Commercial Internet System version 2.0, which is configured with Site Server Personalization and Membership version 3.0.
Modification Type: | Major | Last Reviewed: | 6/12/2001 |
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Keywords: | kbprb KB221104 |
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