Applications Hang When Printing to a Printer Set to "Use Printer Offline" (221092)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Datacenter Server

This article was previously published under Q221092

SYMPTOMS

When you attempt to print from an application on a computer running Windows 2000 to a printer that is set to Use Printer Offline, the application appears to stop responding (hang) while attempting to print.

CAUSE

On the Advanced tab on Printer Properties, the printer is set to Print Directly to Printer. When this is selected in combination with Use Printer Offline, the computer is put into a state where printing cannot take place, because the operating system cannot spool and store the job for later processing on behalf of the application. The application then continues to try to print until the printer is removed from Use Printer Offline state.

RESOLUTION

To prevent this behavior, on the Advanced tab on Printer Properties, click to clear the "Print Directly to Printer" check box; this will allow the computer to spool the job while the printer is offline.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. Install a new printer (local).
  2. Right-click on the new printer, and then click Open.
  3. On the Advanced tab, select Print Directly to Printer, and then click OK.
  4. Right-click on the new printer, and then select Use Printer Offline.
  5. Attempt to print from any installed application.

Modification Type:MajorLast Reviewed:11/21/2003
Keywords:kbprb KB221092