WINS Service Will Not Start with Inconsistent Database (219315)



The information in this article applies to:

  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP1
  • Microsoft Windows NT Workstation 4.0 SP2
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP1
  • Microsoft Windows NT Server 4.0 SP2
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP4

This article was previously published under Q219315

SYMPTOMS

When you configure a computer running Microsoft Windows Internet Name Service (WINS) for WINS replication with more than 255 other WINS servers, the WINS service may stop responding (hang) and the following error may appear in the Event Viewer log:
The Database has been found to be inconsistent. More specifically, the number of owners found in the Name Address Mapping table are different from the number found in the Owner Address Mapping table.

CAUSE

The WINS service tracks other WINS servers in the replication matrix by using a table in the WINS database. This table maps the IP addresses of all other WINS servers to a unique ID number. Each WINS server numbers itself as 0 and assigns other numbers incrementally to new WINS servers as they are discovered through replication. When the table increases past 255 entries, the server removes entries from the owner to IP address mapping table. The number of owners in the Name Address Mapping table and the Owner Address Mapping table are then inconsistent and WINS cannot start.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows NT version 4.0 Service Pack 5.

Modification Type:MajorLast Reviewed:5/13/2003
Keywords:kbbug kberrmsg kbfix kbnetwork kbQFE KB219315