Cannot Navigate to Some FTP Sites Using FTP Folder with Anonymous Logon (219287)
The information in this article applies to:
- Microsoft Internet Explorer 5.0 for Windows NT 4.0
- Microsoft Internet Explorer 5.0 for Windows 98
- Microsoft Internet Explorer 5.0 for Windows 95
This article was previously published under Q219287 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
Some FTP servers require that an e-mail address that contains an "at" sign (@) be submitted as a password during anonymous logons. If the "@" character is missing, the anonymous logon may not succeed.
In some cases, this behavior may occur if a registry entry is corrupted in such a way that a user's logon name is used instead of the e-mail name.
Note that some FTP servers accept the logon name instead of the e-mail name.
CAUSE
This behavior can occur if you log on to a server (normally using a user account), click "Login As" on the File menu, and then click to select the "Anonymous" check box. A registry entry is then changed in such a way that the user name is used for anonymous logons.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To resolve this issue:
- Use Registry Editor to open the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
- Check the data value of the EmailName value. The default value is "IEUser@," "IE30User@", or "IE40User@". If the data value is corrupted, an elipsis (...) is placed after the data value (for example, "IE40User@"...).
- Double-click the EmailName value, or click Modify on the Edit menu. Click OK, and the "..." character should disappear.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 11/14/2003 |
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Keywords: | kbenv kbprb KB219287 |
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