Black Window or Error Message When You Play Video Clip (219047)



The information in this article applies to:

  • Microsoft Encarta 96 Encyclopedia for Windows
  • Microsoft Encarta Encyclopedia 97 Deluxe for Windows
  • Microsoft Encarta 97 Encyclopedia for Windows
  • Microsoft Encarta 98 Encyclopedia for Windows
  • Microsoft Encarta Encyclopedia 99
  • Microsoft Golf 1998 Edition 1.0
  • Microsoft Golf 1999 Edition 1.0
  • Scholastic's Magic School Bus series: Explores in the Age of Dinosaurs for Windows
  • Scholastic's Magic School Bus series: Explores the Human Body for Windows
  • Scholastic's Magic School Bus series: Explores Inside the Earth 1.0
  • Scholastic's Magic School Bus series: Explores the Ocean for Windows 1.0
  • Scholastic's Magic School Bus series: Explores the Rainforest for Windows 1.0
  • Scholastic's Magic School Bus series: Explores the Solar System for Windows 1.0
  • the operating system: Microsoft Windows 95
  • the operating system: Microsoft Windows 98
  • Microsoft Encarta Encyclopedia 99 Concise Edition
  • Microsoft Encarta Encyclopedia Deluxe 99

This article was previously published under Q219047

SYMPTOMS

When you attempt to play a video clip in one of the programs listed at the beginning of this article, you may experience any of the following symptoms:
  • Nothing may happen.

  • A black window may be displayed.

  • A white window may be displayed.

  • You may receive one of the following error messages:
    • MMSYSTEM296: The file cannot be played on the specified MCI device. The file may be corrupt, or not in the correct format.
      Video not available.

CAUSE

This behavior can occur if either of the following conditions are true:
  • Audio-Video Interleave (.avi) files are no longer associated with any media player installed on your computer.

  • The Microsoft AVI File support libraries are missing or damaged.

RESOLUTION

To resolve this issue, associate audio-video interleave (.avi) files with the Microsoft AVI File support libraries. To do this, download and run the Mmsys296.exe file from the Microsoft Download Center.

The following file is available for download from the Microsoft Download Center:
Release Date: Feb-25-1999

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

If the issue continues to occur, extract the Avifil32.dll and Avifile.dll files from your Microsoft Windows CD-ROM or disks to the following folder

drive:\windows\System

where drive is the drive letter of the hard disk on which Windows is installed and windows is the folder in which Windows is installed.

For more information about how to extract files from your Windows CD-ROM or disks, please see the following article in the Microsoft Knowledge Base:

129605 How to Extract Original Compressed Windows Files

MORE INFORMATION

You may be able to play the video clip in Windows Media Player outside of the program if you double-click the file. However, if you right-click the file, click Properties, and then click the Preview tab, you receive the MMSYSTEM296 error message described previously in this article when you attempt to play the video clip.

In addition, the fields on the Details tab contain the contents listed in the following table.

FieldContents
CopyrightNo copyright information.
Media lengthThis file is invalid or corrupted.
Audio format
Video format


NOTE: The Audio Format field may also be empty if the video clip does not contain a sound track.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbdisplay kbenv kberrmsg kbfile kbprb KB219047