SYMPTOMS
When you install Office 2000, Setup may seem very slow to
update the Windows Installer, and then you receive one of the following error
messages:
Internal error 2336: Please Contact Product
Support for assistance.
Internal error 2755: Please Contact Product
Support for assistance.
NOTE: Instead of receiving one of the "internal error" messages
documented in this article, you instead may receive the following error message
after a long wait:
The installer is no longer
responding.
When you create a verbose log file by using
a command line similar to the following
d:\setup.exe /L*V c:\verboselog.txt
and then you open the Verboselog.txt log file in WordPad and
search for the internal error number in the log file, you see text similar to
the following:
MSI (s) (E8:24): Note: 1: 2336 2: 5 3: C:\WINNT\Installer\
MSI (s) (E8:24): MainEngineThread is returning 1632
MSI (c) (F8:C0): Note: 1: 2755 2: 1632 3: D:\data1.msi
Internal Error 2755: Please contact product support for assistance.
CAUSE
This problem occurs when the following conditions are true:
- You install Office 2000 on Windows NT 4.0, Windows 2000, or
Windows XP Professional.
-and- - Windows is installed on an NTFS partition
-and- - The Installer folder does not have correct access
permissions.
NOTE: You can also experience these symptoms if you have only Read
permissions to the WinNT folder. This condition prevents the Installer folder
from being created by Office Setup.