Setup appears to stop responding and you receive an "Internal error 2336" or an "Internal error 2755" error message when you install Office 2000 (217714)



The information in this article applies to:

  • the operating system: Microsoft Windows XP
  • the operating system: Microsoft Windows 2000
  • the operating system: Microsoft Windows NT 4.0
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer
  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Word 2000

This article was previously published under Q217714
For a Microsoft Office XP version of this article, see 297920.

SYMPTOMS

When you install Office 2000, Setup may seem very slow to update the Windows Installer, and then you receive one of the following error messages:
Internal error 2336: Please Contact Product Support for assistance.

-or-

Internal error 2755: Please Contact Product Support for assistance.

NOTE: Instead of receiving one of the "internal error" messages documented in this article, you instead may receive the following error message after a long wait:

The installer is no longer responding.

When you create a verbose log file by using a command line similar to the following

d:\setup.exe /L*V c:\verboselog.txt

and then you open the Verboselog.txt log file in WordPad and search for the internal error number in the log file, you see text similar to the following:

MSI (s) (E8:24): Note: 1: 2336 2: 5 3: C:\WINNT\Installer\
MSI (s) (E8:24): MainEngineThread is returning 1632
MSI (c) (F8:C0): Note: 1: 2755 2: 1632 3: D:\data1.msi
Internal Error 2755: Please contact product support for assistance.

CAUSE

This problem occurs when the following conditions are true:
  • You install Office 2000 on Windows NT 4.0, Windows 2000, or Windows XP Professional.

    -and-
  • Windows is installed on an NTFS partition

    -and-
  • The Installer folder does not have correct access permissions.
NOTE: You can also experience these symptoms if you have only Read permissions to the WinNT folder. This condition prevents the Installer folder from being created by Office Setup.

RESOLUTION

To resolve this problem, change the permissions on the Installer folder. The permissions on the Installer folder should be Everyone - Read Administrators - Full System - Full.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

REFERENCES

For more articles about how to troubleshoot specific errors in Office Setup: For more articles with general information about how to troubleshoot Office errors:

Modification Type:MinorLast Reviewed:10/13/2006
Keywords:kbtshoot kbprb kbstoprespond kbPerformance kberrmsg kbpending kbsetup KB217714