Error message: "The application failed to initialize properly" (217134)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP1
  • Microsoft Windows NT Server 4.0 SP2
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP1
  • Microsoft Windows NT Workstation 4.0 SP2
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4

This article was previously published under Q217134

SYMPTOMS

When you start Windows NT 4.0, you may receive the following error message:
Systray.exe - Application Error

The application failed to initialize properly (0xc0000005)
Click on OK to terminate the application.
You may receive this error message one time for each program you have in the Startup folder.

If you try to start other programs, you may receive the following error message:
Application error: application failed to initialize properly 0xc000005.
When you try to open the Sounds or Multimedia tools in Control Panel, you may receive the following error message:
Error loading mmsys.cpl, invalid access to memory.
When you open Event Viewer, you may receive the following error message:
Event Viewer
The Event Log Service on the local machine is not started.

CAUSE

These error messages can occur if you incorrectly install the Creative Labs Sound Blaster drivers.

RESOLUTION

To resolve this issue, install the Sound Blaster drivers correctly. To do this, follow these steps:
  1. Close all the programs running on your computer.
  2. Click Start, point to Find, and then click Files Or Folders.
  3. In the Named box, type sb16snd.sys sp16snd.dll, and then click Find Now.
  4. Rename the Sb16snd.sys and Sb16snd.dll files to Sb16snd.old and Sb16snd.dl0. For information about how to rename a file in Windows, click Start, click Help, click the Index tab, type renaming: files, and then click Display.

    If you cannot rename the files because they are in use, note the location of the Sb16snd.sys and Sb16snd.dll files, and then follow these steps:
    1. Press CTRL+ALT+Delete, and then click Task Manager.
    2. On the Processes tab, click Explorer.exe, and then click End Process.
    3. On the File menu, click New Task.
    4. In the Open box, type cmd
    5. At the MS-DOS prompt, type cd\folder, where folder is the location of the Sb16snd.sys and Sb16snd.dll files.
    6. Type the following lines, pressing ENTER after you type each line:

      ren sb16snd.sys sb16snd.old
      ren sb16snd.dll sb16snd.dl0
      exit

  5. In Task Manager, click New Task on the File menu, type explorer.exe in the Open box, and then click OK.
  6. Remove and reinstall the Sound Blaster drivers. For information about how to do this, please see the following article in the Microsoft Knowledge Base or contact Creative Labs:

    184327 How to Install Sound Blaster Drivers in Windows NT 4.0


Modification Type:MinorLast Reviewed:1/30/2006
Keywords:kbenv kberrmsg kbprb kbsound KB217134