"Unable to Load Product Specific DLL" Starting Backup (216912)



The information in this article applies to:

  • Microsoft Windows 98

This article was previously published under Q216912

SYMPTOMS

When you start Microsoft Backup (Msbackup.exe), you may receive one of the following error messages:
  • Unable to load product specific DLL. Program will terminate.
  • Unable to load product specific resource DLL.

CAUSE

This error message can occur for either of the following reasons:
  • The Splash.dll file is damaged or missing from the Program Files\Accessories\Backup\System folder.
  • There is a Splash.dll file in the Windows folder.

RESOLUTION

Splash.dll File Damaged or Missing from Program Files\Accessories\Backup\System Folder

To resolve this issue, extract a new copy of the Splash.dll file from your original Windows 98 CD-ROM to the Program Files\Accessories\Backup\System folder. For additional information about extracting files, please see the following articles in the Microsoft Knowledge Base:

129605 How to Extract Original Compressed Windows Files

185836 Description of the System File Checker Tool (Sfc.exe)

Splash.dll File Located in the Windows Folder

Remove or rename the Splash.dll file in the Windows folder.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kberrmsg kbprb KB216912