Unable to KILL Processes or Terminate Down Sessions in Terminal Server (216743)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 Terminal Server Edition
This article was previously published under Q216743 SYMPTOMS
Occasionally, while in Terminal Server, a process will stop responding (hang). Typically, it will be Csrss.exe; sometimes, the Windows NT Virtual DOS Machine (NTVDM) is associated with this process, but not always. When this process stops responding, it may continue to use CPU cycles until the CPU reaches 100 percent utilization.
The affected client will usually disconnect and establish a new session so it can continue work.
The previous session will show up in the Terminal Server Administrator as a DOWN session. The only way to remove this DOWN session is to restart the server, which is not feasible for production-based servers.
CAUSE
This problem may be caused by a 16-bit application that is not behaving properly. You may be able to control Csrss.exe and NTVDM by setting the BadApp information for whatever application caused the problem.
For additional information, see the following article or articles in the
Microsoft Knowledge Base: 186628 Performance Tuning CPU Use for 16, 32-bit Windows Applications
RESOLUTION
To work around this problem, try using the Kill.exe tool on the supplemental resource kit; this works better than the default Kill.exe included with Terminal Server, but it is not completely effective.
STATUSMicrosoft has confirmed that this is a problem in Windows NT 4.0, Terminal Server Edition.
Modification Type: | Major | Last Reviewed: | 6/24/2004 |
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Keywords: | kbbug KB216743 |
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