ERRMSG: A Required Privilege Is Not Held by the Client (216411)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP1
  • Microsoft Windows NT Server 4.0 SP2
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP1
  • Microsoft Windows NT Workstation 4.0 SP2
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4

This article was previously published under Q216411

SYMPTOMS

After you connect through a terminal server client to view or modify the audit properties of a directory on a member server or workstation, you receive the following error message:
A required privilege is not held by the client.
This error can occur even if the account you are using is a member of the Domain Admins global group in the master domain or a resource domain.

CAUSE

The account does not have necessary rights on the terminal server.

RESOLUTION

To resolve this issue, make the user a member of the local Administrators group on the terminal server and the member server/workstation where the user will be configuring the auditing changes.

As a more secure solution, you could simply grant the user the right to Manage auditing and security log on the two computers. The user will then be able to manage auditing on a member server/workstation.

MORE INFORMATION

This is the same error message that a user will receive if he or she tries to manage auditing directly on a computer to which he or she has not been granted the Manage auditing and security log right.

Modification Type:MajorLast Reviewed:6/29/2004
Keywords:kbprb KB216411