OL2000: ErrMsg: A Device Attached to the System is Not Functioning (216154)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q216154

SYMPTOMS

When you start Microsoft Outlook, you receive the following message:

A device attached to the system is not functioning.

followed by:

The OUTLLIB.DLL file is linked to missing export ADVAPI32.DLL:CryptAcquireContextA

CAUSE

You do not have Microsoft Internet Explorer 4.01 or 5.0 installed on your computer. Outlook must have one of these versions of Internet Explorer installed to function.

RESOLUTION

Install either Internet Explorer 4.01 or 5.0. If you do not have an Internet Explorer compact disc (CD), you can either install it from the Microsoft Web site, or you can remove and reinstall Microsoft Office 2000.

Note: Neither the Repair Office nor Add or Remove Features options of Maintenance mode Setup, will install Internet Explorer 5.0.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

To Install Internet Explorer from the Microsoft Web site

Internet Explorer can be installed from the Microsoft Web site at the following address:

To Remove Office 2000

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the Add/Remove Programs icon.
  3. On the Install/Uninstall tab, click to select Microsoft Office 2000, and click Add/Remove.
  4. Click Remove Office, and then click Yes.
When the removal process is finished, reinstall Office.

Modification Type:MajorLast Reviewed:9/29/2003
Keywords:kbbug kbpending KB216154