Sysprep Does Not Rename Accounts Containing the Computer Name (214679)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q214679

SYMPTOMS

Some programs may create user accounts that contain the computer name. For example, Microsoft Transaction Server (MTS) creates an MTS_computer name account on Windows NT-based workstations.

If you set up a computer with such a program installed to be cloned by Sysprep, such user accounts are not renamed for the new computer name.

CAUSE

Sysprep does not look for user accounts that contain the computer name. Also, simply changing the user name is not sufficient because the user name may be stored elsewhere (for example, in the registry, the service account, or private configuration files).

STATUS

Microsoft has confirmed that this is a problem in Sysprep for Windows NT 4.0 and Windows 2000.

MORE INFORMATION

When you set up a computer to clone, use a computer name that will make sense to users if they encounter the local account name (for example, in ACL Editor). For example, use SERVICE_ACCOUNT as the computer name so that MTS Setup creates an account named MTS_SERVICE_ACCOUNT.

Modification Type:MajorLast Reviewed:11/13/2003
Keywords:kbbug kbnofix kbsetup KB214679