WD2000: Characters Appear as Square Boxes in Printed Document (212380)
The information in this article applies to:
This article was previously published under Q212380 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you print a document that contains extended characters, such as Greek
symbols, to certain printers that use printer drivers that do not accept
Unicode characters, the extended characters may be printed as square boxes,
even though they are displayed correctly on the screen.
The problem affects the following printers and printer drivers:
- Canon BubbleJet BJ-C600, 4000, 4200, 4500, 4550, v 3.40
- Canon Multipass 2500 3.40
- Epson Color 500
- Epson Stylus Color, v 2.x
- Epson Stylus Pro / XL v. 2.11BE
- HP Color LaserJet 5 PCL, printer driver version F 1.300
- HP DeskJet 1600C, printer driver version 4.20
- HP LaserJet 4 PCL, printer driver version 3.78
- HP LaserJet 6P, standard printer driver
- Okidata 4 laser printer
CAUSE
This problem occurs because these printer drivers do not provide support
for Unicode characters.
WORKAROUND
To work around this problem, use one of the following methods.
Method 1: Set a Print Flag
There is a flag (registry setting) for the printer driver that causes it to
use American National Standards Institute (ANSI) character layout functions
instead of Unicode character layout functions. When set correctly, this
flag allows the printer driver to print the extended characters correctly.
Use the procedure for setting a print flag that is appropriate to your situation. WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. Procedure 1: Set one registry entry that applies to all installed printers.
To set the registry entry, follow these steps:
- On the Start menu, click Run.
- In the Open box, type regedit and then
click OK.
- Locate the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options
- Double-click the Options key to open it.
- With the Options key selected, on the Edit menu, point to New and click String Value.
- In the right pane, type NoWideTextPrinting and press ENTER.
- With NoWideTextPrinting selected, on the Edit menu, click Modify.
- In the Value Data box, type the value 1 and click OK.
- On the Registry menu, click Exit, and then restart Word.
Procedure 2: Set a flag for an individual printer.
To set the registry entries, follow these steps:
- On the Start menu, click Run.
- In the Open box, type regedit and then click OK.
- Locate the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word
- Double-click the Word key to open it.
- Under the Word key, click to select your printer name.
NOTE: If your printer name is not displayed under the Word key, follow these steps:
- On the Registry menu, click Exit.
- Start Word.
- On the File menu, click Print. Under Printer, select your printer in the Name list, and then click the Close button (the X on the right side of the title bar). If the appropriate printer is already selected, then click Cancel.
- On the Tools menu, click Options.
- Click the Print tab, and then click OK.
- Start Procedure 2 again at step 1.
- With the printer key selected, on the Edit menu, point to New, and click String Value.
- In the right pane, type Flags and press ENTER.
- With Flags selected, on the Edit menu, click Modify.
- In the Value box, type 8192 and click OK.
The printer should now print the extended characters correctly.
Method 2: Printer-Specific Workarounds
The following information describes workarounds that are available for
specific printer drivers. Note that not all printer drivers have a
specific workaround; in this case, Method 1 is the only available
workaround.
HP DeskJet 1600C
To work around this problem, follow these steps:
- On the Start menu, point to Settings, and then click Printers.
- Click the HP DeskJet 1600C ColorSmart printer icon.
- On the File menu, click Properties.
- In the HP DeskJet 1600C ColorSmart Properties dialog box, click the
Details tab, and then click the Setup button.
- In the ColorSmart Setup dialog box, click the Advanced button.
- In the Advanced dialog box, select Use LaserJet III font scaling
and click OK to close each of the open dialog boxes.
HP LaserJet 4 Series PCL
To work around this problem, follow these steps:
- On the Start menu, point to Settings, and then click Printers.
- Click the HP LaserJet 4 printer icon.
- On the File menu, click Properties.
- In the HP LaserJet 4 Properties dialog box, click the Fonts tab.
- In the Fonts dialog box, under TrueType fonts, select Print TrueType
as graphics and click OK.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 8/20/2003 |
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Keywords: | kbbug kbenv kbpending kbprint KB212380 |
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