WD2000: Bar Code Is Unavailable with Envelope Mail Merge (212360)



The information in this article applies to:

  • Microsoft Word 2000

This article was previously published under Q212360

SYMPTOMS

When you create envelopes as part of a mail merge, the Delivery point barcode and FIM-A courtesy reply mail options are unavailable.

CAUSE

The bar code option in the Envelope Options dialog box may not be available if a country other than United States is selected in the Regional Settings dialog box in Control Panel.

WORKAROUND

To work around this problem, use one of the following methods appropriate to your situation.

Method 1: Manually Add the Bar Code

To work around this problem, manually add the FIM-A bar code to the mail merge main document. To do this, follow these steps:
  1. Use the Drawing toolbar to add a text box to the envelope in the approximate location and size for the FIM-A bar code.
  2. Place the insertion point inside the text box.
  3. Type the following field code, where Postal_Code is the name of the field that contains the Zip Codes/Postal Codes in your data file (to create the curly braces, press CTRL+F9):

    {BARCODE "{Mergefield Postal_Code}" \u \f "a" \* mergeformat}

  4. Press ALT+F9, if necessary, to view the FIM-A bar code.
  5. Drag the text box, if necessary, to adjust the position of the FIM-A bar code.
  6. Proceed with the mail merge.

Method 2: Change the Regional Setting to English

To change the regional setting to English, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Regional Settings.
  3. Select English (United States) from the Regional Settings tab.
  4. Click OK, and then click Yes to restart your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The Facing Identification Mark (FIM) identifies the front side of the envelope.

The FIM-A feature is used in two situations: when you create a single envelope outside of a mail merge, and when you perform an envelope mail merge. To add the FIM-A to your envelopes, use the appropriate method for your situation.

Single Envelope

  1. On the Tools menu, click Envelopes and Labels.
  2. On the Envelopes tab, click Options.
  3. On the Envelope Options tab, click to select the Delivery point barcode check box. The FIM-A courtesy reply mail check box then becomes available.
  4. Click to select the FIM-A courtesy reply mail check box.

Envelope Mail Merge

  1. On the Tools menu, click Mail Merge.
  2. Under Main document, click Create, and then click Envelopes.
  3. Click New Main Document to create a new document for the envelopes.
  4. Under Data source, click Get Data to attach a data file or to create a new data file.
  5. After you have attached the data file, click Set Up Main Document.
  6. In the Envelope Options dialog box, click OK.
  7. In the Envelope address dialog box, click Insert Postal Bar Code.
  8. In the Merge field with ZIP code list, click the field name that contains the ZIP Code/Postal Code.
  9. Click to select the FIM-A courtesy reply mail check box, which is now available.
NOTE: If your data source is the Personal Address Book, selecting the FIM-A check box does not generate a FIM-A on the main document for the envelope mail merge.

REFERENCES

For additional information about bar codes, click the article number below to view the article in the Microsoft Knowledge Base:

212221 WD2000: Mail Merge Attached Envelope Does Not Create Bar Codes

For more information about bar codes, click Microsoft Help on the Help menu, type field codes: barcode field in the Office Assistant or the Answer Wizard, and then click Search to view the topics returned.

Modification Type:MinorLast Reviewed:11/22/2005
Keywords:kbbug kbenvelope kbmerge kbnofix kbprint KB212360