XL2000: Error Message Using the Canon MultiPASS C2500 or Bitware Fax Driver (211464)



The information in this article applies to:

  • Microsoft Excel 2000

This article was previously published under Q211464

SYMPTOMS

In Microsoft Excel, when you click Page Setup on the File menu, you may receive the following error message:
This program has performed an illegal operation and will be shut down.
If the problem persists, contact the program vendor.
If you click Details, you receive the following error message:
EXCEL caused an invalid page fault in module MSO97.DLL at 014f:306c34b9.
Note that the address of the invalid page fault that is displayed may vary from the address in this article.

CAUSE

This problem occurs when the following conditions are true:
  • The Canon MultiPASS C2500 multifunction printer driver, version 3.4, is installed on your computer.

    -and-
  • The Canon MultiPASS C2500 printer is your default printer.

    -or-
  • The Bitware Fax driver is installed on your computer and is set as the default printer.

RESOLUTION

Canon MultiPASS C2500

To resolve this problem, obtain the Canon MultiPASS C2500 printer driver, version 3.95 or later. You can obtain and install the newer printer driver from the Canon Web site.

To obtain the driver from the Canon Web site, follow these steps:
  1. Go to the following Web page: http://www.ccsi.canon.com/care

    The driver file c2500.exe (a self-extracting driver file) is available to download as of December 19, 1999.
  2. Click the download link and, when you are prompted, click Save it to disk; save the file in an empty folder on your hard disk.
  3. After you download the file, click Run on the Start menu. In the Open box, type command, and then click OK.
  4. At the command prompt, change to the folder that contains the self-extracting file that you downloaded.
  5. Run the file by typing the file name and pressing ENTER. If you are prompted, do not replace any files.
  6. After you run the file, type exit, and then press ENTER.
Before you install the new printer driver, remove the old printer driver. To do this, follow these steps:
  1. Click Start, point to Settings, and then click Printers.
  2. In the list of printers, click Canon MultiPASS C2500 Printer. On the File menu, click Delete. Click Yes to confirm that you want to delete the printer.
  3. If you are prompted to remove unused files, click Yes.
To install the new printer driver, follow these steps:
  1. In the Printers window, double-click Add Printer, and then click Next.
  2. Click Local printer, and then click Next.
  3. Click Have Disk. In the Install From Disk dialog box, type the path to the new printer driver files that you downloaded, and then click OK.
  4. In the list of printers, click Canon MultiPASS C2500 Printer, and then click Next. If you are prompted to replace the existing driver, click Replace existing driver, and then click Next.
  5. Select a port for the printer (LPT1: for example), and then click Next.
  6. Create a name for the printer, and then choose whether to use the new printer as the default printer. Click Finish.
NOTE: Microsoft does not support the setup and installation of the new printer driver. If you require additional help, contact Canon Technical Support or visit the following Canon Web page: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Bitware Fax Driver

If you set another printer as the default printer, the problem described in this article should no longer occur. You may also want to contact the vendor to see if a newer Bitware Fax driver is available.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The Canon MultiPASS C2500 printer includes a color printer, a copier, a fax machine, and a scanner in one unit. A set of disks that contain the necessary Microsoft Windows 95/98 printer drivers is included with the printer.

The drivers that are included with the printer may cause problems when you display the Page Setup dialog box in Microsoft Excel. If this problem occurs, download and install the newer Canon MultiPASS C2500 printer drivers. Or, contact Canon Technical Support and request a set of disks that contain the newer printer drivers.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/5/2003
Keywords:kb3rdparty kbbug kberrmsg kbpending kbprint KB211464