Web Busy Errors When Authoring FrontPage Webs on IIS (209906)



The information in this article applies to:

  • Microsoft FrontPage 97 for Windows
  • Microsoft FrontPage 98 for Windows
  • Microsoft Internet Information Server 1.0
  • Microsoft Internet Information Server 2.0
  • Microsoft Internet Information Server 3.0
  • Microsoft Internet Information Server 4.0

This article was previously published under Q209906

SYMPTOMS

When you attempt to author to a FrontPage Extended Web on an IIS computer, one of the following error messages occurs:
Web server is busy, please try again later
Web central configuration busy
Web Root is Busy

CAUSE

This is a generic type of error message and is generally due to the server not responding to the request from the client in the allotted time. It can be caused by excessive authoring traffic to a particular virtual server, or a large amount of content in a particular Web (usually in excess of 300 megabytes). This can also be caused by incorrect permissions on the content for the Interactive and Network groups.

Note: Do not attempt to resolve this by editing the NTFS permissions through Windows NT Explorer. Use the steps below.

RESOLUTION

There are several steps to resolve this issue.

First check permissions. To do this, perform the following steps:
  1. Click Start and point to Programs.
  2. Click Microsoft FrontPage 98.
  3. If your Web is in the list, highlight it, click OK, and skip to step 7. If your Web is not in the list, click More Webs and type the name of your server in the box.
  4. Click List Webs.
  5. Highlight your Web and click OK.
  6. On the Tools menu, click Permissions.
  7. On the User tab, remove IUSR_<computername> (if it is there).
  8. On the Groups tab, remove Interactive, Network, and Everyone (if they are listed).
  9. Click Apply.
  10. On the User tab, make sure that the correct radio button is selected to either enable or restrict browse access, based on your preference.
  11. Click OK.
If you found Interactive or Network on the Groups tab, do the following:
  1. Click Start, and then click Run.
  2. Type the following path in the "Open:" box:

    <drive>:\Program Files\Microsoft FrontPage\Version3.0\Bin\Fpsrvwin.exe

    where <drive> is the drive where FrontPage is installed (C by default).
  3. In the Select Server or Port box, highlight your server and click the Check and Fix button.
  4. If you are prompted to tighten security as much as possible, choose Yes.
  5. From a command prompt type:

    net stop iisadmin /y
    net start w3svc
    net start msftpsvc
    net start smtpsvc


If the above steps fail to work or if you receive the error trying to run Check and Fix, do the following:
  1. Click Start, and then click Run.
  2. Type the following path in the "Open:" box:

    <drive>:\Program Files\Microsoft FrontPage\Version3.0\Bin\Fpsrvwin.exe

    where <drive> is the drive where FrontPage is installed (C by default)
  3. In the Select Server or Port box, highlight your server and click the Upgrade button.
This will force a reinstall of the Server Extensions without losing custom permissions.

If the above steps do not fix your issue, try the following:
  1. Click Start, and then click Run.
  2. Type Cmd in the "Open:" box.
  3. Change to the directory above the one that contains your virtual servers.
  4. Issue the following command from the command prompt:

    Cacls foldername /T /E /R iusr_machinename network interactive everyone

    where foldername is the name of the home directory for the virtual server.

    (If you want to run this on multiple virtual servers at the same time, you can replace foldername with *.* and this command will run on all folders below and on their contents.)
  5. Start the FrontPage Server Administrator:
  6. Click Start, and then click Run.
  7. In the "Open:" box, type the following:

    C:\Program Files\Microsoft FrontPage\version3.0\bin\Fpsrvwin.exe

    Note: This is the default path to the location of the installation of FrontPage. Your path may differ.
  8. In the FrontPage Server Administrator, click Check and Fix. (If you are prompted to tighten security as much as possible, choose Yes.)
  9. From a command prompt type:

    net stop iisadmin /y
    net start w3svc
    net start msftpsvc
    net start smtpsvc

  10. At this point, browse access will be restricted.
  11. The following steps need to be done for each virtual server:

    1. Open the root Web with FrontPage. You may receive an error message such as "Cannot open service.lck for writing." If this happens, disable anonymous browsing on the Web server. (You can re-enable it as soon as you have completed step B.)
    2. On the Tools menu, click Permissions.
    3. On the Users tab, select "Everyone has browse access" and click Apply.
    4. Repeat steps B and C for each subweb.

WORKAROUND

If incorrect permissions are not the cause of the problem, you should consider breaking your Webs and virtual servers into smaller sites. There is no recommended way to do this because the logical points to split the content will differ based on your specific needs. The main item to consider is the amount of traffic, due to both browsing and authoring. Your goal should be to balance the traffic evenly.

Below you will find the steps to publish a subweb from one virtual server to another in order to "load balance."

  1. With the subweb you want to publish open in the FrontPage Explorer, click Publish FrontPage Web on the File menu.
  2. Click More Webs.
  3. Type the name of the virtual server you want to publish to, including the name of the subweb to be created as follows:

    http://<servername>/<subwebname>

    where <servername> is the name of the server and <subwebname> is the name of the name of the subweb you are publishing.

    Note: You must be a FrontPage Administrator on the destination server. This is because you will be creating a Web when you publish this way. Creating a Web is a right reserved for FrontPage Administrators.
  4. Click OK.
  5. The Web will now be published to the new location. After the publish is complete, verify that the new Web is functioning properly.
  6. When you have verified that the Web is published correctly, you can delete the old Web.
  7. The FrontPage Explorer should still have the old Web displayed. Verify this by checking the URL in the title bar at the top of the screen.
  8. When you have verified this, click Delete FrontPage Web on the File menu.

    Warning: This will permanently delete the content, as well as the old Web. Make sure that you have a backup before doing this.

    Note: You must be a FrontPage Administrator on the Web you are deleting in order to delete the Web. Only administrators can delete Webs.
  9. When the new Web is up and running, direct your authors to connect to the new location when they are authoring or publishing.


Modification Type:MajorLast Reviewed:12/8/2003
Keywords:kbprb KB209906