Error Messages in DLLs After Installing an IEAK Package with a CMAK Profile (209283)



The information in this article applies to:

  • Microsoft Internet Explorer Administration Kit 4.01a

This article was previously published under Q209283

SYMPTOMS

After you use the Internet Explorer Administration Kit (IEAK) to create a custom Microsoft Internet Explorer package that includes a custom Connection Manager Administration Kit (CMAK) version 1.0 profile, a number of error messages may be displayed. These error message may include or be similar to:
Cannot run the deleteie3cache function not in file or exported in wininet.dll
Delete ie3 cache
Cannot run dllinstall in Comctl32.dll.
A client computer may also display a number of "RunDLL" error messages after being restarted.

CAUSE

This behavior occurs because the CMAK version 1.0 package installs older Internet Explorer 3.x versions of the Wininet.dll and Comctl32.dll files after Internet Explorer 4.01 is installed. The newer versions of these files are required.

RESOLUTION

To resolve this issue:
  1. Run the CMAK Wizard to rebuild the CMAK profile.
  2. In the "Specify browser requirements" screen, select the Require Internet Explorer 3.0 or later option.

    If the No browser requirements option is selected, the installation does not succeed and the error messages listed above are displayed.
  3. After you finish creating the CMAK profile, run the IEAK Wizard and select the new CMAK profile.
This generates an Internet Explorer installation that works correctly and does not replace the new .dll files with older files.

MORE INFORMATION

This issue does not occur with a CMAK profile that is generated with CMAK version 1.2 that is available with IEAK version 5 and Microsoft Windows 2000 Server.

Modification Type:MajorLast Reviewed:12/31/1999
Keywords:kbenv kberrmsg kbprb KB209283