ACC2000: Cannot Convert Database Without Default Printer (208288)



The information in this article applies to:

  • Microsoft Access 2000

This article was previously published under Q208288
Novice: Requires knowledge of the user interface on single-user computers.

ERROR MESSAGE

When you try to convert or open a Microsoft Access 2.0 database, you may receive the following error message
The process failed because there is no printer installed.
This may be followed by the message:
Microsoft Access failed to create the Visual Basic module 'Form_<Form Name>'.
This is followed by the message:
Microsoft Access failed to convert or enable your code modules.
NOTE: Microsoft Office 2000 has built-in functionality that allows you to get more information about difficult-to-troubleshoot alerts or error messages. If you want to enable this functionality for this and other error messages in Microsoft Office 2000, please download the Microsoft Office 2000 Customizable Alerts file from the Microsoft Office Update Web site at the following address: NOTE: If you reached this article by clicking the Web Info button in an error message, you already have Customizable Alerts enabled.

CAUSE

You do not have a default printer installed.

THINGS TO TRY

Use the Add Printer wizard to install a printer. To do so, follow these steps:
  1. Click Start, point to Settings, and then click Printers.
  2. Double-click Add Printer, and follow the instructions.
NOTE: Note that some printers have their own setup routines that bypass the Add Printer wizard. Follow the instructions in your documentation.

MORE INFORMATION

In Microsoft Access, you cannot create a report if you do not have a default printer installed. When you convert a database created with Microsoft Access 2.0, a default printer is also required because Microsoft Access will create a new database and import the objects as new objects.

For more information about converting databases, click Microsoft Access Help on the Help menu, type convert a database in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

Modification Type:MinorLast Reviewed:12/2/2005
Keywords:kbdownload kberrmsg kbprb KB208288