User With Change Permissions Only has Browse Access Once FrontPage Extensions are Installed (206935)



The information in this article applies to:

  • Microsoft FrontPage 97 for Windows
  • Microsoft FrontPage 98 for Windows
  • Microsoft Internet Information Server 3.0
  • Microsoft Internet Information Server 4.0

This article was previously published under Q206935

SYMPTOMS

When you install the FrontPage Server Extensions to a Web site, users who have full control, add and read, or change permissions can only browse the site; they cannot author or administer the site as expected.

CAUSE

The installation of the FrontPage Server Extensions resets the permissions on _vti_bin and its contents.

RESOLUTION

Open the Web in FrontPage and do the following:

  1. On the Tools menu, click Permissions.
  2. On the Users tab, double-click the user and change the level of access to Author and Browse, or Administer, Author, and Browse, depending your preference.
  3. Click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

FrontPage applies NTFS permissions to the _vti_bin folder and its contents in a very specific way. Users who have permissions on the content have read permissions on the _vti_bin folder and its contents with the exception of _vti_aut and _vti_adm. Permissions on those folders are as follows:

System - Full Control
Administrators - Full Control
The account specified as an administrator during the install - Read (RX)(RX)


Modification Type:MajorLast Reviewed:12/8/2003
Keywords:kbbug kbnofix KB206935