"User Unknown" Error Message When Using Small Business Server Modem Sharing Client (202004)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a

This article was previously published under Q202004
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When using the Modem Sharing client included with Small Business Server (SBS), you may receive one of the following error messages in the Modem Sharing event viewer on a Microsoft Windows 95 or Microsoft Windows 98 client
  • 19:10:1998 11:05:00 [User: "<UNKNOWN>", Resource: "Modem Sharing Port (COMx)"] : Open port error 1006 (UserName not found)
  • 19:10:1998 11:05:00 [User: "", Resource: "Modem Sharing Port (COMx)"] : Open port error 1006 (UserName not found)
where x is the number of the COM port that is redirected to the modem pool of the SBS-based computer.

You may also notice that Modem Sharing appears to skip the COM port that is redirected to the server's modem pool when Modem Sharing attempts to detect a modem.

CAUSE

This behavior occurs if the UserName registry value is blank or missing.

RESOLUTION

To work around this issue, use the appropriate method.

Method 1: Disable the Option to Clear the UserName Value Using the TweakUI Tool

  1. Click Start, point to Settings, click Control Panel, and then double-click Tweak UI.
  2. On the Paranoia tab, click to clear the Clear Last User at Logon check box, and then click OK.
  3. Restart the computer.

Method 2: Disable the DontShowLastUser Value in the Registry

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry key:

    HKEY_LOCAL_MACHINE\Network\Logon

  3. Change the DontShowLastUser value to 0.
  4. Quit Registry Editor.

Method 3: Manually Add the UserName Value to the Registry

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry key:

    HKEY_LOCAL_MACHINE\Network\Logon

  3. On the Edit menu, point to New, and then click String Value.
  4. Type username for the value name.
  5. Type the name of the user that is currently logged on for the Data value.
  6. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in BackOffice Small Business Server 4.0 and 4.0a.

Modification Type:MajorLast Reviewed:10/3/2003
Keywords:kbbug kberrmsg kbfix KB202004