PRB: Sample Gateway Fails to Start with a Logon Failure (200668)



The information in this article applies to:

  • Microsoft Exchange Development Kit (EDK) 4.0
  • Microsoft Exchange Development Kit (EDK) 5.0
  • Microsoft Exchange Development Kit (EDK) 5.5

This article was previously published under Q200668

SYMPTOMS

When you start the sample gateway, you may get an event ID in the application log that states the service could not start due to a logon failure.

CAUSE

This can be caused by having duplicate Ipm_in.dll and Ipm_out.dll keys in the registry.

RESOLUTION

Check these keys in your registry as follows:
  1. Run Regedit.

    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


    Go to the key HKey_Local_Machine\Software\Classes\Mapi Conversions. You should have the following two keys under this:

    Ipm_in.dll
    Ipm_out.dll

    You should not have duplicates of these keys.
  2. Go to the key HKey_Local_Machine\Software\Classes\Mapi Conversions. You should have the following two keys under this:

    Ipm_in.dll
    Ipm_out.dll

    You should not have duplicates of these keys.

STATUS

This behavior is by design.

MORE INFORMATION

Under the Ipm_in.dll key, there should be one key called GetTrivialVector. This key holds three values:

Classes: REG_MUTI_SZ: MESSAGE.IPM REPORT.IPM
OPTIONS: REG_SZ:
Point:REG_SZ:SAMPLEGW.INBOUND


The Ipm_out.dll key is similar with the only difference being the Point value is SAMPLEGW.OUTBOUND

Modification Type:MinorLast Reviewed:3/4/2004
Keywords:kbMsg kbprb KB200668