BUG: ADSI Windows 95 ADO Error "ADO Could Not Find the Specified Provider" (200650)
The information in this article applies to:
- Microsoft Active Directory Service Interfaces 2.0
- Microsoft Windows 95
This article was previously published under Q200650 SYMPTOMS
Attempts to open an ADODB.Connection on Windows 95 with the connection provider set to ADSDsOObject returns the following error message.
Error 3706 : ADO Could Not Find the Specified Provider
-or
Error 3021 : no current record
CAUSE
The installer in the web release of Active Directory Services Interfaces (ADSI) version 2.0 for Windows 95 (Adsw95.exe 10/16/97 12:04AM) creates an invalid key name under the provider CLSID.
RESOLUTION
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.
- On the taskbar, select Start, and then click Run.
- Type REGEDIT and click OK to open the Registry Editor.
- Using the Registry Editor go to the following key:
<WWBLOCKQUOTE>
HKEY_CLASSES_ROOT/CLSID/{549365d0-ec26-11cf-8310-00aa00b505db}/OLEDBProvider
</WWBLOCKQUOTE> - Rename the key to:
<WWBLOCKQUOTE>
HKEY_CLASSES_ROOT/CLSID/{549365d0-ec26-11cf-8310-00aa00b505db}/OLE DB Provider
</WWBLOCKQUOTE>
Note the additional spaces.
STATUS
Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article.
MORE INFORMATION
This problem has been corrected in latest version of ADSI.
REFERENCES
For additional information about ADSI, please see the following web site:
| Modification Type: | Minor | Last Reviewed: | 3/20/2004 |
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| Keywords: | kbDSWManage2003Swept kbAPI kbbug KB200650 |
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