Setting Knowledge Manager on a Virtual Server (200501)



The information in this article applies to:

  • Microsoft Knowledge Manager
  • Microsoft Site Server 3.0

This article was previously published under Q200501

SYMPTOMS

When Knowledge Manager is set to a different virtual server with a different TCP port, the category tree search will fail with a permission error.

CAUSE

The SEARCHLEFT.asp is not designed to work with a different TCP port by default.

RESOLUTION

It is possible to rerun the Kmsetup.vbs. Since the change is a global change there is only one Knowledge Manager (KM) that can exist on one server.

To run the Kmsetup.vbs follow these steps:
  1. Go to command line
  2. Go to <microsoft site server>\ bin \ p&m
  3. Run Km_setup.vbs cscript Km_setup.vbs <servername> <tcp port>

    where:
    • <servername> = the server name where KM is located
    • <tcp port> = the new TCP port that corresponds to the new virtual server

WORKAROUND

If a different KM will be created on one server, the ASP code that handles the category tree needs to be modified.

Modify the <microsoft site server>\siteserver\knowledge\searchleft.asp by the following line of code:
Dim sURL: sURL = "HTTP://" & Request.ServerVariables("SERVER_NAME") &
Request.ServerVariables("URL")
				
Notice the code does not contain the port number variable.

Change the code to the following:
Dim sURL: sURL = "HTTP://" & Request.ServerVariables("SERVER_NAME") & ":" &
Request.ServerVariables("SERVER_PORT") & Request.ServerVariables("URL")
				

STATUS

Microsoft has confirmed this to be a problem in Site Server version 3.0.

Modification Type:MajorLast Reviewed:9/19/1999
Keywords:kbbug KB200501