ACC97: Can't See Dialog Box on System That Had Dual Monitors (200412)



The information in this article applies to:

  • Microsoft Access 97

This article was previously published under Q200412
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry


Moderate: Requires basic macro, coding, and interoperability skills.

SYMPTOMS

Certain Microsoft Access dialog boxes may be orphaned--not visible--on a Microsoft Windows system that once had two or more monitors installed at the same time. You cannot select the dialog box to move it back to the primary monitor.

If this condition occurs, you may not be able to see the property sheet associated with tables, forms, queries, or reports. This can also occur with the field list associated with forms or reports, the Indexes dialog box associated with tables, and the Sorting and Grouping dialog box for reports.

CAUSE

You may experience this behavior when a dialog box appears on a secondary monitor, and you then remove that monitor.

A registry key records the last position of the dialog box in question; therefore, the dialog box opens in the saved position.

RESOLUTION

This section describes a remedy for orphaned Access dialog boxes.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


  1. Verify that a backup file of the registry exists.
    For additional information about the registry, please see the following articles in the Microsoft Knowledge Base:

    183887 Description of the Windows Registry Checker Tool (Scanreg.exe)

    183603 How to Customize Registry Checker Tool

  2. On the taskbar, click Start, and then click Run.
  3. Type regedit in the Run dialog box. Click OK.
  4. Browse to the following key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Access\Settings

  5. Delete the key corresponding to the window that is orphaned:
    WindowKey
    Table PropertiesTDPopPropST
    Table IndexesIndexesST
    Query PropertiesQueryPopPropST
    Form PropertiesFormPopPropST
    Report PropertiesReportPopPropST
    Report Sorting and GroupingSGST
    Form or Report Field ListECLST

  6. On the Registry menu, click Exit.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Open a form in Design view.
  2. On the View menu, click Properties.
  3. Drag the Properties dialog box to the secondary monitor.
  4. Quit all programs.
  5. Turn off the computer.
  6. Remove the secondary monitor card.
  7. Turn on the computer, and the start Microsoft Access.
  8. Open a form in Design view. Note that you do not see the Properties dialog box.
  9. On the View menu, click Properties. Note that you still do not see the Properties dialog box.

Modification Type:MajorLast Reviewed:9/26/2003
Keywords:kbprb KB200412