ERD Recovery Process Halted - Insert Compaq SSD in Drive A (199835)
The information in this article applies to:
- Microsoft Windows NT Server 3.51
- Microsoft Windows NT Server 4.0
- Microsoft Windows NT Workstation 3.51
- Microsoft Windows NT Workstation 4.0
This article was previously published under Q199835 SYMPTOMS
When you restore system files by using the emergency repair disk (ERD) that has been run on a Compaq system on which Compaq Support Software Disks (SSDs) have been applied prior to running RDISK, you may receive the following message:
Insert Compaq NT Support Software Disk into Drive A:
There is not an option to redirect the location in which to find the file or files in question. If you insert a Compaq Support Software Disk (SSD) into drive a, the message still occurs and the files cannot be located.
The ERD process is trapped in a loop and the only option at the time is to prematurely end system recovery.
CAUSE
During the installation and upgrade of Compaq SSDs, the Setup.log file is annotated. In most cases, the Netflx3.sys line is as follows:
\WINNT4\System32\drivers\NetFlx3.sys="netflx3.sys","13604","\","Compaq NT Support Software Disk",""
If the Compaq Management CD, which contains the Compaq Insights Agents, has been applied, the Sysmgmt.sys argument has been changed as described below:
\WINNT4\System32\Drivers\Sysmgmt.sys="SYSMGMT.SYS","21008","\SYSMGMT","Compaq Support Software 1.20 for Microsoft Windows NT(TM), Diskette #1","CPQNTSSD"
NOTE: The above lines should be continuous and have been wrapped for readability. Also, there can be additional lines that also include "Compaq Support Software..."
After you apply the Compaq SSD and then run RDISK, the Setup.log file on the ERD will be annotated with the changes.
Unfortunately, there is not a corresponding .inf file for the drivers. After the ERD recovery process parses the Setup.log, it prompts for a Compaq Windows NT Support Software Disk; however, the information needed to install the drivers does not exist.
RESOLUTION
To work around this problem, follow these steps: - Delete or remark the following lines in the Setup.log file and then save changes:
\WINNT4\System32\drivers\NetFlx3.SYS="netflx3.sys","13604","\","Compaq NT Support Software Disk",""
\WINNT4\System32\Drivers\Sysmgmt.sys="SYSMGMT.SYS","21008","\SYSMGMT","Compaq Support Software 1.20 for Microsoft Windows NT(TM), Diskette #1","CPQNTSSD"
- Remove the hidden, system, and read-only attributes on the Setup.log file on the ERD (either at a command prompt using attrib -r -h -s or through Windows NT Explorer).
- Go through the ERD restore process again; it should complete successfully.
To resolve this problem in the future, you can edit the Setup.log file on the local hard drive of the system in question. The Setup.log file resides on %systemroot%\WINNT\repair and also has the hidden, system, and read-only attributes.
Modification Type: | Major | Last Reviewed: | 8/10/2001 |
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Keywords: | kbprb KB199835 |
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