ACC2000: Replica Remains in Synchronize Dialog Box After Deletion (199067)



The information in this article applies to:

  • Microsoft Access 2000

This article was previously published under Q199067
Moderate: Requires basic macro, coding, and interoperability skills.

SYMPTOMS

A replica that you have deleted or moved still appears in the Directly with Replica list box when you point to Replication on the Tools menu and then click Synchronize Now. The replica also appears in Replication Manager when you click All Replica Sites on the View menu.

CAUSE

Deleted or moved replicas are not automatically removed from the available list of replicas that can be synchronized.

RESOLUTION

If you want to remove a replica that no longer exists from the list of available replicas, follow these steps:
  1. On the Tools menu, point to Replication, and then click Synchronize Now.
  2. Select the replica in the Directly with Replica list, and click OK.
  3. Click Yes in the message box that asks you if you want Microsoft Access to close and synchronize.
  4. Click OK in the message box that tells you that the replica can't be found.
  5. Click OK in the message box that tells you Microsoft Access has deleted the replica and asks if you want to close and reopen the database now.

    Note that in some cases the database does not close; however, the replica name is removed from the list. If this happens, click Cancel in the Synchronize Database dialog box to reset the database.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Open the sample database Northwind.mdb.
  2. On the Tools menu, point to Replication, and then click Create Replica.

    Click Yes when prompted "This database must be closed before you can create a replica."

    Click Yes when prompted to create a backup of your database before converting it to the design master.
  3. When the replica is created, note the folder to which Microsoft Access copies the replica. Click OK.
  4. On the Tools menu, point to Replication, and then click Synchronize Now. Note that the new replica appears in the list of replicas that you can synchronize with. Click Cancel.
  5. Using Windows Explorer, find the replica and delete it from the folder.
  6. Return to Microsoft Access and on the Tools menu, point to Replication, and then click Synchronize Now.

    Note that the replica still appears in the list, and that if you try to click OK, you receive a message that Microsoft Access cannot find the replica.

REFERENCES

For more information about replication problems, click Microsoft Access Help on the Help menu, type troubleshoot replication problems in a database in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

Modification Type:MinorLast Reviewed:7/13/2004
Keywords:kbprb KB199067