FIX: ADO: Unable To Update Memo Field > 64K In Access Database (198532)
The information in this article applies to:
- Microsoft OLE DB Provider for Jet 3.51
- ActiveX Data Objects (ADO) 2.0
- ActiveX Data Objects (ADO) 2.1
- ActiveX Data Objects (ADO) 2.5
- Microsoft Data Access Components 2.0
- Microsoft Data Access Components 2.5
- Microsoft Visual Basic Professional Edition for Windows 5.0
- Microsoft Visual Basic Professional Edition for Windows 6.0
- Microsoft Visual Basic Enterprise Edition for Windows 5.0
- Microsoft Visual Basic Enterprise Edition for Windows 6.0
This article was previously published under Q198532 SYMPTOMS
An attempt to update a large (64K or greater) memo field in a client-side
recordset using the Jet 3.51 OLE DB provider results in one of the following
errors:
Errors occurred.
Run-time error '-2147217887(80040e21)':
-or-
Run-time error '-2147217259(80040005)':
Data provider or other service returned an E_FAIL status.
CAUSE
This problem is caused by a bug in the Microsoft OLE DB Provider for Jet
version 3.51.
RESOLUTION
This problem only occurs when using the Microsoft OLE DB Provider for Jet
version 3.51 and client-side recordsets.
This problem does not occur if you use the Microsoft Access ODBC driver or
a server-side recordset.
STATUS
Microsoft has confirmed this to be a bug in the Microsoft products listed
at the beginning of this article.
This bug has been fixed in the Microsoft OLE DB Provider for Jet versions 4.0 and later.
| Modification Type: | Minor | Last Reviewed: | 3/14/2005 |
|---|
| Keywords: | kbADO210sp2fix kbbug kbfix kbJET kbMDACNoSweep KB198532 |
|---|
|