SNMP Status for Printers Is Not Displayed with SPM Printing (198176)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q198176

SYMPTOMS

After you create a local printer by using the Transmission Control Protocol/Internet Protocol (TCP/IP) Standard Port Monitor (SPM) on your Windows 2000-based server running Microsoft Internet Information Server (IIS), when you try to view this printer's properties by using your Web browser program, the detailed device status is unavailable on the Web page for that printer. Note that this may occur even though the SNMP Status is enabled for the port.

CAUSE

This issue can occur because the SPM uses SNMP to obtain the printer's status. SMP supports TCP/IP network printers regardless of whether or not they support SNMP, although it only supplies simple status information for those devices.

RESOLUTION

To determine if your Network Print Server device supports SNMP view the manufacturer's documentation for that device.

MORE INFORMATION

The following is an excerpt from the Tcpmon.ini file that shows information about the Emulex Internal MIO adaptor card:
   name       = "Emulex Internal MIO card"
   ports      = 1
   protocol1  = "LPR"
   queue1     = "PASSTHRU"
   snmp1      = "NO"
				
NOTE: SNMP1= "NO" means that SNMP status is disabled because this device does not support it.

Other SNMP values stated in the Tcpmon.ini file are "Yes and "?". "Yes" means that the device supports SNMP and the SNMP Status Enabled check box is selected by default when the SPM port is created. because of this, you receive detailed "Device Status" information when viewing this printer's Web page that should include a real time view of the printer's front panel display. The "?" means that SPM polls the print device when the port is created to determine if SNMP is supported.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/5/2003
Keywords:kbprb kbprint KB198176