FIX: Upgrading DTC to Close Idle Connections (197810)
The information in this article applies to:
- Microsoft Transaction Server 2.0
- Microsoft COM
This article was previously published under Q197810 IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, make sure you understand how to restore it if
a problem occurs. For information about how to do this, view the "Restoring
the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key"
Help topic in Regedt32.exe.
SYMPTOMS
Microsoft Distributed Transaction Coordinator (DTC) coordinates distributed
transactions using the two-phase commit process. A DTC transaction manager
implements the two-phase commit process by exchanging two-phase commit
messages with the other DTC transaction managers participating in the
transaction. These two-phase commit messages flow over connections that the
DTC transaction managers establish with one another. To conserve network
resources, a transaction manager establishes a network connection only when
it is needed. If a connection remains idle for a certain amount of time,
the transaction manager closes the connection. Transaction managers monitor
the state of the connections by exchanging periodic ping messages. These
ping messages ensure that the connection is still available. They are also
used to detect when a connection is idle. After a certain number of pings
have been exchanged while no transactions are active on the connection, the
idle connection will be closed.
CAUSE
A problem in the code caused the connections to be inadvertently held open
for up to 10 hours. This problem is corrected in Hotfix 0655a which allows
connections to be held open for 10 minutes rather than 10 hours.
In addition to correcting this problem, DTC now provides the ability to
control both the ping frequency and the time an idle connection will remain
open.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Transaction
Server version 2.0. This problem has been fixed in Microsoft Windows NT 4.0 Service Pack 4 (SP4).
A supported fix is now available, but has not been fully regression-
tested and should be applied only to systems experiencing this specific
problem. Unless you are severely impacted by this specific problem,
Microsoft recommends that you wait for the next Service Pack that contains
this fix. Contact Microsoft Product Support for more information.
This problem has been fixed in COM+.
Modification Type: | Minor | Last Reviewed: | 3/16/2005 |
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Keywords: | kbBug kbDSupport kbDTC KB197810 |
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