Share for Deleted Fax Printer Remains in Registry (196973)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.0

This article was previously published under Q196973
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information on how to do this, view the "Restoring the Registry" online Help topic in Regedit.exe or the "Restoring a Registry Key" online Help topic in Regedt32.exe.

SYMPTOMS

Any attempt to fax or make changes to the Fax Server tool in Control Panel cause an error message stating that the service is not started. The Microsoft Fax Service will be shown as started in the Services tool in Control Panel, but any attempt to start or stop the service will produce errors stating the service is not responding.

Additional symptoms include:
  • Many instances of the following error in event viewer:
    Event ID 8221; spooler cannot manage fax job
  • When removing a fax printer using the Fax Server tool in Control Panel, the queue will not be deleted from the Printers folder.

CAUSE

The fax queue is still entered in the registry as a shared resource, but all other entries for the queue have been removed successfully.

RESOLUTION

To resolve this problem, manually delete the fax share.

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it. If you are running Windows NT, you should also update your Emergency Repair Disk (ERD).
  1. Click Start, point to Settings, click Control Panel, and then double- click Services.
  2. Stop the Microsoft Fax Service and the Spooler Service.
  3. Run Registry Editor (Regedt32.exe)
  4. Go to the following key:
    HKEY_LOCAL_MACHINE\System\Current Control Set\Services
          \LanmanServer\Shares
    						
    NOTE: The above registry key is one path; it has been wrapped for readability.
  5. Verify that the only print shares are for existing printers and fax machines. If previously deleted shares are listed, save the key and proceed to the next step.
  6. Remove values for any fax or print shares that were previously deleted.
  7. Restart the Spooler Service and the Microsoft Fax Service.

Modification Type:MajorLast Reviewed:2/24/2004
Keywords:kbprb KB196973