SBS: Proxy Will Not Start If Clients Folder Is Deleted (196969)
The information in this article applies to:
- Microsoft BackOffice Small Business Server 4.0
This article was previously published under Q196969 SYMPTOMS
If the %SystemDrive%\SmallBusiness\Clients folder is deleted or moved and
the Small Business Server (SBS) computer is restarted, Proxy will fail to
start and the following error will be displayed:
Initialization of the dynamic link library
C:\WINNT.SBS\system32\MSPHLPR.dll failed. The process is terminating
abnormally.
Also, IIS services will not start as they depend on the Proxy service to be
running.
CAUSE
The Msplat.txt file, which has local address table (LAT) information in it,
is currently saved in the %SystemDrive%\SmallBusiness\Clients\MS\Proxy
folder. Deleting this directory structure deletes this file, which Proxy
depends on during startup.
RESOLUTION
To work around this problem, re-create the missing directory structure
(%SystemDrive%\SmallBusiness\Clients\MS\Proxy) and copy the Msplat.txt file
from a client workstation on the %SystemDrive%\Mspclnt folder into the
servers re-created folder.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article.
MORE INFORMATION
If the LAT is updated or customized, it is advisable to save a copy of this
file to a safe location so that it may be restored quickly in the event
that this file is ever damaged or lost.
Modification Type: | Major | Last Reviewed: | 10/3/2003 |
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Keywords: | kbbug kbpending KB196969 |
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