OL98: (CW) How to Troubleshoot Missing Internet E-Mail Service (196722)
The information in this article applies to:
This article was previously published under Q196722
NOTE: These procedures only apply if you have installed Outlook with the
Corporate Workgroup/Other option. This option allows you to use Messaging
Application Programming Interface (MAPI) services. To determine your
installation type, on the Help Menu click About Microsoft Outlook. In About
Microsoft Outlook you should see "Corporate" if you have the Corporate
Workgroup installation.
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, make sure you understand how to restore it if
a problem occurs. For information about how to do this, view the "Restoring
the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key"
Help topic in Regedt32.exe.
SYMPTOMS
You are using the Corporate or Workgroup installation of Microsoft Outlook
98 configured with the Internet E-mail service in your profile. You are not
able to send mail and the Internet E-mail service does not appear in either
the Mail Services dialog box or under Send And Receive on the Tools menu.
CAUSE
This condition may occur when certain components that make up the Internet
E-mail service are damaged or not properly registered.
RESOLUTION
This section describes several possible resolution methods. The methods are
in order, from least difficult to most difficult. Try each method in order,
testing after completing each one for proper Internet E-mail configuration
and functionality.
NOTE: Because there are several versions of Windows, the following steps
may be different on your computer. If they are, please consult your product
documentation to complete these steps.
MORE INFORMATIONBasic Steps to Rename Files
In the methods listed below, you often need to locate and rename certain
files. To do this in each method, follow these steps:
- Quit all programs.
- Click Start, point to Find and click Files Or Folders.
- In the Named box, type the name of the file you want to locate, as described in each method.
- In the Look In list, click to select your hard disk.
- Click to select the Include Subfolders check box, and click Find Now.
- To rename the located file, right-click the item and then click Rename on the shortcut menu. Edit the name by changing the extension of the
file to ".old" (without the quotation marks).
NOTE: In some cases, you need to use the asterisk (*) character to do "wildcard" searches. For example, in order to find all files that are in
the Messaging Application Programming Interface (MAPI) family, you would
type "Mapi*.*" (without the quotation marks) in the Named box. This query
returns files such as Mapi.dll, Mapi32.dll, and Mapisvc.inf, among others.
Method 1If You Use Windows 95/98
These steps assume that you installed Outlook in the Microsoft Office 97
default installation path.
- Quit Outlook and any other programs that are currently running. Click the Start button, point to Programs and click MS-DOS Prompt.
- In the MS-DOS Prompt window, type (include quotation marks):
cd "\program files\microsoft office\office"
and then press ENTER. - In the MS-DOS Prompt window, type:
c:\windows\system\regsvr32 outlmime.dll
and then press ENTER. You will receive the following message:
DllRegisterServer in outlmime.dll succeeded.
Click OK and then click the Close button to close the MS-DOS prompt
window.
NOTE: In the above step, you may need to type the full path to the System folder.
- Start Outlook and send a mail message to test your mail functionality.
If You Use Windows NT 4.0- Quit Outlook and any other programs that are currently running. Click the Start button, point to Programs and click Command Prompt.
- In the Command Prompt window, type:
cd\program files\microsoft office\office
- In the Command Prompt window, type (include quotation marks):
c:\winnt\system32\regsvr32 outlmime.dll
NOTE: In the above step, you may need to type the full path to the System32 folder.
You will receive the following message:
DllRegisterServer in outlmime.dll succeeded.
- Click OK and click the Close button to close the Command Prompt window.
Method 2- Using the steps described earlier in the "Basic Steps to Rename Files" section, locate and rename all occurrences of the following files on
your hard disk:
Mspst32.dll
Minet.ecf
Minet32.dll
Wsock32n.dll
-
Click Start, point to Settings and then click Control Panel.
- Double-click the Add Remove Programs icon.
- In the list of programs click Microsoft Outlook 98, and click Add/Remove.
- In the Outlook Active Setup dialog box, click Rerun Outlook 98 Setup.
- After completing the reinstallation, start Outlook and test for
Internet E-mail functionality.
NOTE: You may need to create a new profile after reinstallation.
Method 3- Using the steps described earlier in the "Basic Steps to Rename Files"
section, locate and rename all occurrences of the following files on
your hard disk:
Mapi.dll Outllib.dll
Mapi32.dll Outlmime.dll
Mapisp32.exe Outlook.exe
Mapisrvr.exe
- Click Start, point to Settings and then click Control Panel.
- Double-click the Add/Remove Programs icon.
- In the list of programs, click Microsoft Outlook 98, and click Add/Remove.
- In the Outlook Active Setup dialog box, click Rerun Outlook 98 Setup.
-
After completing the reinstallation, start Outlook and test for
Internet E-mail functionality.
NOTE: You may need to create a new profile after reinstallation.
Method 4
If you are using Windows 98, remove and reinstall Outlook Express, an e-
mail and newsreader component of Microsoft Internet Explorer. To do this,
follow these steps:
- Click Start, point to Settings and then click Control Panel.
- Double-click the Add Remove Programs icon.
- In the list of programs, click Microsoft Outlook Express and click Add/Remove. When prompted, click Yes to remove Outlook Express.
- In the Add/Remove Programs dialog box, click the Windows Setup tab and then click to select Microsoft Outlook Express. Click OK to install Outlook Express.
NOTE: You need to insert the Windows 98 compact disc into your
CD-ROM drive for this step. - After completing the reinstallation, start Outlook and test for
Internet E-mail functionality.
NOTE: You may need to create a new profile after reinstallation.
Method 5
If the methods described earlier do not resolve the problem described in
the "Symptoms" section, you need to remove Outlook and perform further
maintenance before reinstalling.
WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.
For information about how to edit the registry, view the "Changing Keys And
Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete
Information in the Registry" and "Edit Registry Data" Help topics in
Regedt32.exe. Note that you should back up the registry before you edit it.
To remove Outlook and perform the specified file maintenance, follow these
steps:
- Click Start, point to Settings and then click Control Panel.
- Double-click the Add/Remove Programs icon.
- In the list of programs, click Microsoft Outlook 98.
- In the Outlook Active Setup dialog box, click Remove Outlook 98.
- If you do not have Office 97, skip this step and proceed to step 6.
If you have an Office 97 compact disc, use the steps described earlier in the "Basic Steps to Rename Files" section to locate and rename all occurrences of the following files on your hard disk:
Mfc40.dll (Default path C:\Windows\System)
Mssetup.dll (Default path C:\Program Files\Microsoft Office\Office\
Setup\Outlook)
Msvcrt40.dll (Default path C:\Windows\System)
Then, copy these same files from the Office 97 compact disc and paste
them in the same location where the renamed files are located. - Using the steps described earlier in the "Basic Steps to Rename Files" section, locate and rename all occurrences of the following files on
your hard disk:
Mapi.dll Jobexec.dll
Mapi32.dll Psapi.dll
Mapisp32.exe Inseng.dll
Acmeeng.inf Softpub.dll
Wintrust.dll Outsetup.inf
Wininet.dll Outlwzd.exe
IMPORTANT: Do not rename the following files if running Microsoft Windows 98:
Wininet.dll
Wintrust.dll
Then, copy these same files from the Office 97 compact disc and paste
them in the same location where the renamed files are located. - Click Start and click Run. In the Open box, type "regedit"
(without the quotation marks), and click OK.
- In Registry Editor, locate the following Registry subkey (folder):
HKey_Local_Machine\Software\Microsoft\Active Setup - On the Registry menu, click Export Registry File. Type a name for the registry file and click Save to save the entry to your desktop. This procedure creates a backup of the subkey.
- Right-click the subkey (folder) and then click Delete on the shortcut menu.
- In Registry Editor, locate the following Registry subkey (folder):
HKey_Current_User\Software\Microsoft\Active Setup - On the Registry menu, click Export Registry File. Type a name for the registry file and click Save to save the entry to your desktop. This procedure creates a backup of the subkey.
- Right-click the subkey (folder) and click Delete on the shortcut menu.
- Using the steps described earlier in the "Basic Steps to Rename Files" section, locate and rename all occurrences of the following files on
your hard disk if they exist:
Msdownld.tmp
Ixp.tmp
Ol98logs
Then, copy these same files from the Office 97 compact disc and paste
them in the same location where the renamed files are located. - Use either the Outlook 98 compact disc or an Active Setup file
obtained from the Web to run Outlook Active Setup.
- After completing the reinstallation, start Outlook and test for
Internet E-mail functionality.
NOTE: You may need to create a new profile after reinstallation.
Method 6
You should only attempt the final method after attempting each of the
previous four methods. To complete this more extensive method, follow these
steps:
- Close all currently running programs.
- Press CTRL+ALT+DELETE, check the Task Manager or Close Program dialog box for any additional programs that may be running. Select each item in the Close Program list and then click End Task. Complete this
operation, confirming the End Task operation each time, until only Explorer and Systray are running.
- Click Start, point to Settings and then click Control Panel.
- Double-click the Add Remove Programs icon.
- In the list of programs click Microsoft Outlook 98, and click
Add/Remove.
- In the Outlook Active Setup dialog box, click Remove Outlook 98.
- Click Start, click Shutdown, and then click Restart or "Restart the computer." Wait for Windows to restart.
- Click Start, point to Settings and then click Control Panel.
- Double-click the Add/Remove Programs icon.
- In the list of programs, click Microsoft Office 97 and then click
Add/Remove. Insert your Office 97 compact disc when prompted.
- In the Office 97 Maintenance program, click Remove All.
- Using the instructions provided in following Knowledge Base article,
obtain, install and run Eraser97.exe.
For additional information about Eraser97, please click the article number below to view the article in the Microsoft Knowledge Base:
176823 OFF97: Utility to Completely Remove Remaining Office 97 Files
- Click Start, click Shutdown, and then click Restart or "Restart the computer." Wait for Windows to restart.
- Press CTRL+ALT+DELETE, check the Task Manager or Close Program dialog
box for any additional programs that may be running. Select each item
in the Close Program list and then click End Task. Complete this
operation, confirming the End Task operation each time, until only
Explorer and Systray are running.
- Using the steps described earlier in the "Basic Steps to Rename Files" section, locate and rename all occurrences of the following files on your hard disk if they exist:
Mapi*.dll Outl*.dll Wab32.dll Inetcomm.dll
Mapi*.exe Outl*.exe Pstprx32.dll Minet32.dll
Mapi*.ini Outl*.ini Msimnui.dll
Mapi*.inf Ems*.* Contab32.dll
NOTE: Depending on the installation type and mail services you are
using, some of these files may not exist on your computer. For
example, you may not have files that match the Ems*.* query because
these files allow the Corporate or Workgroup installation to collaborate
in an Microsoft Exchange Server environment. - Locate and then delete each of the following files:
Extend.dat
Outcmd.dat
Frmcache.dat
Reinstalling Office 97 and Outlook 98
To ensure a clean installation of Office 97 and Outlook 98 after completing
Method 5, follow these steps:
- Press CTRL+ALT+DELETE, check the Task Manager or Close Program dialog
box for any additional programs that may be running. Select each item
in the Close Program list and then click End Task. Complete this
operation, confirming the End Task operation each time, until only
Explorer and Systray are running.
- Using the Microsoft Office 97 Compact disc, run Setup to install
Office. Select the Custom Option and then click to clear the Outlook 97 check box.
-
Repeat step 1 to close all running programs.
- Using either the Outlook 98 compact disc or a Setup utility downloaded from the Outlook Web site, run Outlook Active Setup and select the options you want to complete the installation.
Modification Type: | Major | Last Reviewed: | 6/11/2002 |
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Keywords: | kbhowto kbprb KB196722 |
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