PRB: Acmsetup Caused IPF in Kernel32.dll - Dell Inspiron 3200 (196497)
The information in this article applies to:
- Microsoft Visual Studio, Enterprise Edition 6.0, when used with:
- the operating system: Microsoft Windows 95
- the operating system: Microsoft Windows 98
- Microsoft Visual C++, 32-bit Editions 6.0
- Microsoft Visual Basic Learning Edition for Windows 6.0
- Microsoft Visual Basic Professional Edition for Windows 6.0
- Microsoft Visual Basic Enterprise Edition for Windows 6.0
- Microsoft Visual InterDev 6.0
- Microsoft Visual J++ 6.0
- Microsoft Visual FoxPro for Windows 6.0
This article was previously published under Q196497 SYMPTOMS
If you are installing one of the above products onto a Dell Inspiron 3200
laptop computer under Windows 98, you might receive an error similar to the
following:
Acmsetup cause an invalid page fault in kernel32.dll at 015F:BFF7F188
CAUSE
One possible cause is a hardware error in the CD-ROM drive. So far,
Microsoft has only seen this hardware problem affect installation of
software under Windows 98 and Windows 95. Microsoft has not received any
reports of problems when you install the software under Microsoft Windows NT 4.0 or Microsoft Windows 2000.
Also, this problem is more likely to occur if DMA access is enabled, but it
can occur even after disabling DMA access.
RESOLUTION
First try disabling Direct Memory Access (DMA) access in the Windows 98
Device Manager. For information on how to do this, please see the following
article in the Microsoft Knowledge Base:
190630 OFF97: Kernel32.dll Error Installing Products with DMA Enabled
If that does not resolve the problem, check to see what kind of laptop CD-
ROM you have and do the following:
- If it is a Toshiba 24x CD-ROM drive, remove the CD-ROM drive. It's a
removable CD-ROM drive, so this should not be difficult.
- Look at the barcode on the bottom. It should contain either A00, A01, or
A02.
NOTE: the A01 and A02 models do not have any known problems with
Visual Studio 6.0 setup.
- If the barcode contains A00, contact technical support at Dell and
ask to have your CD-ROM drive replaced.
If your CD-ROM drive is an A01, A02, or some other drive type, the problem
is not as clear. You should look for other possible causes in the Microsoft
Knowledge Base and consider contacting Microsoft Product Support. For
information on contacting Microsoft Product Support, please see the
following Web page:
If you must install Visual Studio before your new CD-ROM drive arrives from
Dell, remove the CD-ROM drive and install Visual Studio from some location
other than the CD-ROM drive. Either install from a network location or from
a removable media other than a CD or copy the CD to the hard drive. In all
cases, avoid using the CD-ROM drive in the laptop and leave it out of the
machine. If you copy the CD to a Jazz drive or to the hard drive, you must
use the CD-ROM drive in another computer.
Modification Type: | Major | Last Reviewed: | 8/1/2006 |
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Keywords: | kb3rdparty kbprb kbsetup KB196497 |
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