FP2000: Navigation Bars Don't Show up on Search Results Page (196477)
The information in this article applies to:
This article was previously published under Q196477 For a Microsoft FrontPage 98 version of this article, see 183034.
SYMPTOMS
When you submit a search on a page containing the FrontPage Search
component, the results are returned, but the navigation bars on the page
are gone.
CAUSE
This behavior occurs when the server hosting your web is running Microsoft
Index Server. When you save a page that contains a Search Form component,
FrontPage creates an .idq file. Index server to uses this file to
determine which folders and files to search. FrontPage also creates a
template file to be used for the results. This file is stored in the
_derived folder and is named <filename>.htm0.htx (where <filename> is the
name of the file that contains the Search Form component). Because this
template file is not in the navigation structure of the web, the
navigation bars do not appear in the Web browser.
RESOLUTION
To work around this behavior, use one of the following methods:
Method 1: Use a Standard Form and a Custom .idq File
Use a standard form and create a custom .idq file to be used with Index
Server. For additional information, please see the following article in
the Microsoft Knowledge Base:
166357FP: How to Use FrontPage with Microsoft Index Server
Method 2: Use the FreeWAIS Search Engine
Use the FreeWAIS search engine included with the FrontPage Server
Extensions. For additional information, please see the following article
in the Microsoft Knowledge Base:
181204FP: Using FrontPage Search Engine Instead of MS Index Server
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 9/26/2001 |
---|
Keywords: | kbbug KB196477 |
---|
|