ODBC Logging May Stop if Database Connection is Lost (196445)
The information in this article applies to:
- Microsoft Proxy Server 2.0
This article was previously published under Q196445 SYMPTOMS
If Proxy Server 2.0 is configured to log on to a SQL Server database and
the database connection gets lost, Proxy Server 2.0 may stop logging until
the corresponding Proxy Server service is restarted. The loss of the
database connection may occur because SQL Server was stopped.
CAUSE
The Proxy Server 2.0 ODBC logging module does not support the reconnection
of lost database connections.
RESOLUTION
A supported fix that corrects this problem is now available from
Microsoft, but has not been fully regression-tested and should be applied
only to systems experiencing this specific problem.
To resolve this problem immediately, contact Microsoft Product Support
Services to obtain the fix. For a complete list of Microsoft Product
Support Services phone numbers and information on support costs, please go
to the following address on the World Wide Web:
The English version of this fix should have the following file attributes
or later:
Date Time Size File name Platform
------------------------------------------------
01/06/99 03:26AM 62,224 Msplog.dll (x86)
01/06/99 03:26AM 103,184 Msplog.dll (Alpha)
STATUS
Microsoft has confirmed this to be a problem in Proxy Server version 2.0.
MORE INFORMATION
With the updated Msplog.dll installed, the Proxy Server logging module now
detects a lost database connection whenever it attempts to write a log
record. After a one-minute timeout, when another log request comes in, it
tries to reconnect to the database and continues logging upon the next log
request. If the reconnection to the database does not succeed, it will be
retried once a minute whenever a log request comes in. This process is
handled separately for every Proxy Server service.
Modification Type: | Minor | Last Reviewed: | 9/22/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbQFE KB196445 |
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