XADM: Replication Fails After Disaster Recovery (196406)
The information in this article applies to:
- Microsoft Exchange Server 4.0
- Microsoft Exchange Server 5.0
- Microsoft Exchange Server 5.5
This article was previously published under Q196406 SYMPTOMS
After you follow standard disaster recovery procedures, the restored server
appears to fail both in replication and mail transfer. All services start
successfully and no errors are encountered.
Prior to the recovery, the server was deleted from the site through the
Exchange Server Administration program.
CAUSE
Removing a server from the site forces all other servers to purge the
server from the list of valid servers in the site to be replicating with.
When the server (both information store and directory service) is restored
from backup after you Create a New Site in Exchange Server Setup, the other
servers in the site will not begin replication with the server because
there is no Reps-To or Reps-From raw value entries for the deleted server.
The Reps-To and Reps-From entries are only created on "Joining An Existing
Site" in Exchange Server Setup.
WORKAROUND
There are two possible options to restore the server to the original site:
- Directory Restore - Depending on the size of the organization, each
directory could be restored to their original servers with a backup time
prior to the deletion. Each server must remain offline until all
restores have been completed.
- Rebuilding the Directory - A more practical workaround to organizations
larger that a few servers is to build a new directory. If the removed
server was the system folder server for the site, perform the steps in
the following Microsoft Knowledge Base article prior to continuing:
152960
XADM: Reassigning Site Roles after Removing the First Server in an Exchange Site
- From the Exchange Administrator Program, on the Tools menu, click
Directory Export and export all Recipient containers and Distribution
Lists on this server. If possible, export these to the templates
provided on the Exchange 4.0 Server CD (Support\Samples\Csvs) to
ensure all valid data fields are populated. Verify the data after
export.
- In Control Panel Services, stop the Microsoft Exchange System
Attendant. When prompted, click OK to stop all of the other Microsoft
Exchange Server services.
- Copy the Pub.edb, Priv.edb, all Edb*.log files, all Res*.log files
and the Edb.chk file to another directory or another server as a
backup.
- Run Setup.exe from the Exchange Server CD, and click Remove All when
prompted. Verify and remove all Exchange directories (across all
drives if Optimization was run).
- Using the Exchange Administrator program on another server, remove
this server from the site if it is visible. Allow replication to
occur -- the time will depend on the links between the other
servers in the site.
- Run Setup.exe again, and join the existing site. This will provide
the installation with the same Organization Name and Site Name as
before.
NOTE: Remember to reapply any Service Packs applied in the previous
installation. - In Control Panel Services, stop the Microsoft Exchange System
Attendant. When prompted, click OK to stop all of the other
Microsoft Exchange Server services.
- Move all the files out of the Exchsrvr\Mdbdata directory (across all
drives if Optimization was run). Copy to this directory the all files
that were copied to another directory or server in step 1 (Pub.edb,
Priv.edb, all Edb*.log files, all Res*.log files and the Edb.chk
file).
- Start the Microsoft Exchange System Attendant and Microsoft Exchange
Directory services in Control Panel Services.
- From a command prompt, change directories to Exchsrvr\Bin, and carry
out the following command:
- Start the remaining Microsoft Exchange Server services in the
Control Panel Services tool.
- Run the Microsoft Exchange Server Administrator Program against the
server you are reintroducing.
- If there were any other Recipients container aside from the default
Recipients container, make sure the containers have replicated from
one of the other servers in the site before the restore.
- Using the comma separated value (CSV) files created in Step 1, on
the Tools menu, click Directory Import and import the Directory
entries into the Directory.
At this point, all Users should show up in their respective containers.
After these procedures are done, the users will be able to log into
the server without having lost their mail messages and the public
folders will have been restored as well.
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
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Keywords: | kbprb KB196406 |
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