OL2000: Multiple Category Contacts Don't Filter as Expected (196256)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q196256

SYMPTOMS

A custom view of contacts that is filtered on multiple categories may not be displayed as expected, even if one or more of the categories in a contact do not match the filter criteria.

CAUSE

The logical operator used in filtering contacts is an implied OR. It is not exclusive.

MORE INFORMATION

The filter uses an implied OR function. There is no way to create an exclusive AND condition. This means that a contact that meets any of the filtering criteria is displayed, even if it also contains an additional category not mentioned in the filtering criteria.

Steps to Reproduce Problem

The following steps demonstrate the behavior of filtering views based on multiple categories:

  1. Create several contacts that contain A, B, and C categories. Have some that contain the category A, others that contain the categories A and B, others that contain the categories A, B, and C, and finally others that contain the categories A and C.
  2. On the View menu, point to Current View, and then click Customize Current View. Click Filter.
  3. On the More Choices tab, click Categories, and then click to select the categories A and B. Click OK, OK, and OK to close the dialog boxes and apply the filter.
RESULTS: Contacts that have categories of (A and B), (A, B, and C), (A and C), and (B and C) will be displayed. You will see the categories of A, B, and C listed in the view.

Modification Type:MajorLast Reviewed:9/29/2003
Keywords:kbprb KB196256