Access Violation in Addusrw.exe May Occur in Manage Server (196097)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0a

This article was previously published under Q196097

SYMPTOMS

When you add a new user or update user properties by using the Manage Server Console, you may encounter an access violation and subsequent Dr. Watson errors. In addition to these errors, it is possible that the CPU usage may reach up to 100 percent for an extended period of time, causing your server to stop responding (hang).

CAUSE

The cause of these errors is either a missing or incompatible version of the Dapi.dll file. This file may not be present or incorrect for the following reasons:
  • During the upgrade of Small Business Server (SBS) 4.0 to SBS 4.0a, the installation experienced errors copying the files.
  • During the upgrade of Microsoft Exchange Server 5.0 to Exchange Server 5.5, a single file was not copied.

RESOLUTION

To resolve the errors, replace the Dapi.dll in %SystemRoot%\System32 with the latest file. The correct file can be found on the SBS Service Pack 1 or Exchange Server 5.5 Service Pack 1. The correct file has the following file information:
   File name   Size     Date       Time
   -----------------------------------------
   Dapi.dll    311 KB   1/12/98    12:00 A.M.
				
When experiencing this error and using Exchange Server 5.5, simply reapply Service Pack 1 for Exchange Server 5.5

Modification Type:MajorLast Reviewed:11/7/2003
Keywords:kbprb KB196097