XADM: Deadlock in STORE Due to a Stack Overflow (195971)



The information in this article applies to:

  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.0

This article was previously published under Q195971

SYMPTOMS

The Microsoft Exchange information store may stop responding (hang) because of a stack overflow when processing a corrupted message. After this happens, the client cannot log on to the Exchange Server computer and cannot send or receive a message.

CAUSE

This happens because the message contains a corrupted attachment, in this case, there is no "END" section for the encoded attachment. When the information store encounters an incomplete sequence at the end of the encoded line, it keeps appending more data, but makes no progress with decoding.

RESOLUTION

Exchange Server 5.5

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For more information, please see the following article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack



The English version of this fix should have the following file attributes or later:

Component: Information Store

File NameVersion
Gapi32.dll 5.5.2446.0
Mdbmsg.dll5.5.2446.0
Store.exe5.5.2446.0

Exchange Server 5.0

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next version of Exchange Server 5.0 that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

Component: Information Store

File NameVersion
Mdbmsg.dll5.0.1461.91
Store.exe5.0.1461.91

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Serverversions 5.0 and 5.5.

Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB195971