ACTPU(ERP)/ACTLU(ERP) Requests Not Sent To Downstream Systems (195401)
The information in this article applies to:
- Microsoft SNA Server 2.11
- Microsoft SNA Server 2.11 SP1
- Microsoft SNA Server 2.11 SP2
- Microsoft SNA Server 3.0
- Microsoft SNA Server 3.0 SP1
- Microsoft SNA Server 3.0 SP2
- Microsoft SNA Server 3.0 SP3
- Microsoft SNA Server 4.0
- Microsoft SNA Server 4.0 SP1
This article was previously published under Q195401
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, make sure you understand how to restore it if
a problem occurs. For information about how to do this, view the "Restoring
the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key"
Help topic in Regedt32.exe.
SYMPTOMS
SNA Server fails to send ACTPU(ERP) and ACTLU(ERP) requests to devices
connected to SNA Server as DSPUs (Downstream PUs) even when it receives
ACTPU(ERP) and ACTLU(ERP) requests from its upstream connection to a
mainframe. In these cases, SNA Server sends ACTPU(COLD) and ACTLU(COLD)
requests to the DSPUs.
If the DSPU doesn't support ACTPU(COLD) or ACTLU(COLD) requests, the DSPU
may reject the request with an error response with an IBM Sense Code of
0x'0835'. This sense code is defined as Invalid Parameters.
In one reported case, the DSPU was an IBM AIX system running IBM's
Communications Server for AIX. In this case, the AIX system rejected the
ACTLU(COLD) request from the SNA Server with a IBM Sense Code of
0x'08350001', where 0x'0001' is the offset of the rejected request that
caused the problem. Offset 0x'0001' of an ACTLU Request contains the
setting for the activation type requested, which is either COLD or ERP.
Please refer to the IBM SNA Formats Guide (GA27-3136) for more details on
the ACTPU and ACTLU RUs (Request Units). This manual also includes
information on IBM Sense Codes.
In addition, the SNA Server may log an event similar to the following in
the Windows NT Application Event Log when this occurs:
Event ID: 20
Source: SNA Server
Description: Negative Response Received on Connection
<connection name>
(SENSE = 0835)
CAUSE
SNA Server was not correctly sending ACTPU(ERP) and ACTLU(ERP) requests to
DSPUs because it was ignoring the registry entries used to control how
ACTPU(ERP) and ACTLU(ERP) requests are to be handled.
RESOLUTIONSNA Server 3.0To resolve this problem, obtain the latest service pack for SNA Server version 3.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
184307 How to Obtain the Latest SNA Server Version 3.0 Service Pack
SNA Server 4.0
This problem was corrected in the latest SNA Server version 4.0 U.S.
Service Pack.
For information on obtaining this Service Pack, query on the following word
in the
Microsoft Knowledge Base (without the spaces):
S E R V P A C K
STATUS
Microsoft has confirmed this to be a problem in SNA Server versions 2.11,
2.11 Service Pack 1, 2.11 Service Pack 2, 3.0, 3.0 Service Pack 1, 3.0
Service Pack 2, 3.0 Service Pack 3, 4.0, and 4.0 Service Pack 1.
This problem was first corrected in SNA Server 3.0 Service Pack 4.
Modification Type: | Minor | Last Reviewed: | 4/21/2005 |
---|
Keywords: | kbbug kbfix KB195401 |
---|
|