PRB: Custom Import of a Large User List May Cause an LDAP Timeout (195387)
The information in this article applies to:
- Microsoft Site Server 3.0
This article was previously published under Q195387 SYMPTOMS
During the import of a large user list, Custom Import reports the
following error message:
The import was unable to finish because of the following problem. The
LDAP server may not be configured correctly. Please set the Max Query
Timeout value to 0 (unlimited) and the Max ResultSet value to
Unlimited.
The following error is reported in the application event log:
Source: P&M Directory Store
Description:
SQL Error: HRESULT: 80040e31 Minor Code: 0 Source: Microsoft OLE DB
Provider for ODBC Drivers Description: [Microsoft][ODBC SQL Server
Driver]Timeout expired SQLErrorInfo: 0, S1T00
CAUSE
This occurs because the SQL Server computer takes longer to respond to an
LDAP query than the LDAP application allows.
RESOLUTION
To resolve this problem, use the Site Server Administration MMC to increase the LDAP query timeout by performing the following steps:
- Select Personalization and Membership.
- Select the LDAP server, and expand the server entry to list the membership instances.
- Select the membership instance, and expand it.
- Select the LDAP service, and click Properties.
- In the LDAP Properties page, click the Directory Properties tab.
- Under Master databases on this partition, select the database that is listed.
- Click the Edit button.
- In the Database Server Properties dialog box, specify the Default Timeout parameter by increasing the value from 60 seconds to 600 seconds.
NOTE: You must perform steps 6-8 for each individual SQL database.
STATUS
Microsoft has confirmed this to be a problem in Site Server version 3.0.
Modification Type: | Major | Last Reviewed: | 10/21/2000 |
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Keywords: | kbprb KB195387 |
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