PRB: CDO (1.x) Cannot See New Incoming Messages in Personal Folders (195380)
The information in this article applies to:
- Collaboration Data Objects (CDO) 1.1
- Collaboration Data Objects (CDO) 1.2
- Collaboration Data Objects (CDO) 1.21
This article was previously published under Q195380 SYMPTOMS
If you designate a Personal Folders store as the delivery location for your
incoming messages, your Collaboration Data Objects (1.1, 1.2, 1.21) application fails to see new incoming messages.
CAUSE
The new mail has not been transferred to the Personal Folders store yet.
CDO (1.1, 1.2, 1.21) does not register for server notifications, therefore, delivery of the new messages to the Personal Folders store does not occur automatically.
RESOLUTION
Following are two alternatives:
- Run Microsoft Outlook before processing the new messages in your CDO
(1.1, 1.2, 1.21) code. The server advises Microsoft Outlook when new mail arrives, which results in the transfer of new messages to the Personal Folders store.
-or-
- Use the DeliverNow method of the CDO (1.1, 1.2, 1.21) Session object before referring to any message item in your Inbox. The DeliverNow method requests the Messaging Application Programming Interface (MAPI) Spooler to deliver all messages in the inbound queues immediately.
STATUS
This behavior is by design.
REFERENCES
For more information on setting mail delivery to a Personal Folders file,
please see the following article in the Microsoft Knowledge Base:
182062
OL98: Working with Personal Folders
Modification Type: | Minor | Last Reviewed: | 3/4/2004 |
---|
Keywords: | kbMsg kbprb KB195380 |
---|
|