Error: "No Transport Provider" Trying to Send Mail in Terminal Server (194878)
The information in this article applies to:
- Microsoft Outlook 97 8.0, when used with:
- the operating system: Microsoft Windows 98
- the operating system: Microsoft Windows 95
- Microsoft Outlook 97 8.01, when used with:
- the operating system: Microsoft Windows 98
- the operating system: Microsoft Windows 95
- Microsoft Outlook 97 8.02, when used with:
- the operating system: Microsoft Windows 98
- the operating system: Microsoft Windows 95
- Microsoft Outlook 97 8.03, when used with:
- the operating system: Microsoft Windows 98
- the operating system: Microsoft Windows 95
- Microsoft Outlook 98 8.5, when used with:
- the operating system: Microsoft Windows 98
- the operating system: Microsoft Windows 95
- the operating system: Microsoft Windows NT 4.0
This article was previously published under Q194878 SYMPTOMSOutlook 98 and Outlook 97
When Outlook is configured for Internet mail, sending mail with this
service you will receive a non-delivery report (NDR) stating, "No transport
provider was available for delivery to this recipient. The service is
installed but doesn't show up in Tools/Check for new mail on..."
CAUSE
Outlook clients need to create an RHC file in the %systemroot%\system32
directory. The complete filename for the RHC file is:
MSIN****RHC
where **** is going to be a different number for each user.
The default permission on the System32 directory is:
Everyone Read (RX)
Change this to:
Everyone Change
and uncheck:
Replace permissions on Subdirectories and Replace permissions on
existing files.
RESOLUTION
Changing the permissions on the System32 directory to Everyone Change
(RWX)(RWX) will allow users when running Outlook to create these files.
STATUS
This behavior is by design.
Modification Type: | Major | Last Reviewed: | 5/14/2003 |
---|
Keywords: | kbprb KB194878 |
---|
|