FPNW Client Does Not Get Correct Time or Date After Y2K (194726)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q194726

SYMPTOMS

When an MS-DOS-based NetWare client attaches or logs on to a Windows NT Server computer running File and Print Services for NetWare (FPNW), the client's date and time are not synchronized with that of the server when the server's date and time are beyond 12/31/1999 at 11:59:59pm.

CAUSE

FPNW fails to provide the proper date and time information to the client for synchronization when the server's date is past 12/31/1999 at 11:59:59pm.

RESOLUTION

Windows NT 4.0

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


The English version of this post-SP3 hotfix has been posted to the following Internet locations.

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

MORE INFORMATION

Novell's NETX or VLM NetWare shells running on an MS-DOS-based client synchronize the client's clock with that of the NetWare server being attached to. Like Novell's Login.exe, FPNW's Login.exe also synchronizes the client's clock with that of the server when run.

If one of these MS-DOS-based clients attaches or logs on to an FPNW server anytime before 12/31/1999 at 11:59:59pm, the client's time and date will be updated to match that of the server being attached or logged into. If the client attaches or logs on to an FPNW server after 12/31/1999 at 11:59:59pm, the client's time will be updated to the correct time, but the client's date will not be updated.

NOTE: Microsoft Windows NT clients running Client Services for NetWare (CSNW) or Gateway Services for NetWare (GSNW), and Microsoft Windows 95 or Windows 98 clients running the Microsoft Client for NetWare networks do not synchronize the workstations' clocks when attaching or logging on to NetWare servers.

For more information on what is fixed in Y2K2-fix, please see the following articles in the Microsoft Knowledge Base:

175093 User Manager Does Not Recognize February 2000 As a Leap Year

180122 After Changing the Time, Windows NT May Skip a Day

183123 Find Files Displays Garbled Date if Year is 2000 or Greater

183125 Shell Doc Property Dialog Custom Date Incorrect after Year 2000

184132 Err Msg: Value Entered Does Not Match with the Specified Type

186669 FPNW Logout.exe Incorrectly Reports Year After Jan. 1, 2000

191768 Date of Print Job May Be Displayed Incorrectly in Print Queue

193056 Problems in Date/Time after Choosing February 29 in a Leap Year

193434 Migration Changes NetWare Accounts Expiration Date

207799 IBM PS/1 will not Boot on or After January 1, 2000

216916 NTBACKUP Writes Incorrect Year to Log File

Windows NT Server 4.0, Terminal Server Edition

For information on the Y2K2-fix for Windows NT 4.0, Terminal Server Edition, please see the following article in the Microsoft Knowledge Base:

196548 Y2K Update for Windows NT 4.0, Terminal Server Edition


Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB194726