WD97: WordPerfect 5.x File Appears Corrupt When Opened in Word (194566)



The information in this article applies to:

  • Microsoft Word 97 for Windows

This article was previously published under Q194566

SYMPTOMS

When a document that was originally saved as WordPerfect 5.0/5.1 format from within WordPerfect version 2.0, 2.12, or 3.0 for the Macintosh is opened in Microsoft Word, the document may appear corrupted or you may receive the following error message:
Document appears to be corrupt
The corrupted appearance also occurs with files saved from WordPerfect 3.0 for the Macintosh as WordPerfect 2.1 for the Macintosh format and opened in Word for the Macintosh using the WordPerfect 2.0 for the Macintosh converter.

In each case, blocks and other "garbage" (corrupted data) may appear throughout the converted document.

CAUSE

This problem occurs because WordPerfect versions 2.x and 3.0 for the Macintosh do not always export a 100-percent standard WordPerfect for MS-DOS document, and WordPerfect 3.0 for the Macintosh doesn't always export a 100-percent valid WordPerfect 2.1 for the Macintosh document.

The WordPerfect converters supplied with Word for the Macintosh, Word for Windows, and Word for MS-DOS are optimized to read a valid WordPerfect document but cannot work around nonstandard structure if generated by WordPerfect for the Macintosh.

WORKAROUND

Method 1

If you are using WordPerfect 3.0 for the Macintosh, save your documents as Rich Text Format (RTF) instead, and open from this format in Word.

Method 2

If you have WordPerfect for the Macintosh documents and you only have access to WordPerfect for MS-DOS or WordPerfect for Windows, follow these steps:

  1. Open the document in WordPerfect for MS-DOS or Windows.
  2. Paginate the document (in WordPerfect for MS-DOS, press HOME, HOME, DOWN ARROW, followed by HOME, HOME, UP ARROW, and in WordPerfect for Windows scroll to the bottom of your document and then back to the top).
  3. Resave and attempt to open in Word.
NOTE: This is a workaround that may not resolve the problem in every instance.

MORE INFORMATION

The third-party products mentioned here are manufactured by Corel Corporation, a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.

Support for WordPerfect 3.0 for the Macintosh, WordPerfect 5.x for DOS, and WordPerfect for Windows is the sole responsibility of Corel Corporation. For more information or technical support, contact Corel Customer Support.

For information about how to contact Corel, query in the Knowledge Base for one of the following articles: For additional information about , please click the article number(s) below to view the article(s) in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z


Modification Type:MajorLast Reviewed:11/14/2000
Keywords:kbconversion kbprb KB194566